Bug 889766 - Warning message when running openstack-db -y --init --service glance --rootpw openstack
Warning message when running openstack-db -y --init --service glance --rootpw...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity unspecified
: snapshot2
: 2.1
Assigned To: Eoghan Glynn
Attila Fazekas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-23 07:10 EST by Gary Kotton
Modified: 2016-04-26 22:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: openstack-glance-2012.2.1-5.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:24:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 925609 None None None Never
OpenStack gerrit 14177 None None None Never
OpenStack gerrit 5031 None None None Never

  None (edit)
Description Gary Kotton 2012-12-23 07:10:41 EST
Description of problem:
Get warning message when invoking command in summary:

[root@gkotton-rhel64-1 ~]# openstack-db -y --init --service glance --rootpw openstack
Verified connectivity to MySQL.
Creating 'glance' database.
Asking openstack-glance to sync the database.
/usr/lib/python2.6/site-packages/migrate/changeset/schema.py:554: SAWarning: <type 'NoneType'> being associated with <class 'sqlalchemy.schema.Column'> object after the <class 'sqlalchemy.schema.Column'> has already been used in a SQL generation; previously generated constructs may contain stale state.
  self.table = None
/usr/lib/python2.6/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_add_disk_format.py:46: SADeprecationWarning: useexisting is deprecated.  Use extend_existing.
  useexisting=True)
Complete!


Version-Release number of selected component (if applicable):


How reproducible:
100% if no database exists


Steps to Reproduce:
1. Run command in summary
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Eoghan Glynn 2013-01-03 10:53:10 EST
Already fixed upstream with:

  https://review.openstack.org/5031
  https://review.openstack.org/14177

These fixes, though trivial, touch the migrate_repo scripts ... however in this case, we can allow them onto stable/folsom as only *pre-existing* scripts are touched and the resulting DB is unchanged.
Comment 3 Eoghan Glynn 2013-01-25 11:53:24 EST
The first patch, https://review.openstack.org/5031, is already backported to stable/folsom.

Whereas the second patch, https://review.openstack.org/14177, was not backported at the time of landing on master.

I've addressed this oversight as:

  https://review.openstack.org/20492
Comment 4 Eoghan Glynn 2013-01-25 15:08:21 EST
Landed upsteam on stable/folsom:

  https://github.com/openstack/glance/commit/4c960803
Comment 8 errata-xmlrpc 2013-02-14 13:24:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0260.html

Note You need to log in before you can comment on or make changes to this bug.