Bug 889774 - Quantum client requires gedit or kate
Quantum client requires gedit or kate
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cmd2 (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
low Severity low
: snapshot4
: 2.1
Assigned To: Martin Magr
Ofer Blaut
: Triaged
: 910858 (view as bug list)
Depends On:
Blocks: quantum_ovs_tracker
  Show dependency treegraph
 
Reported: 2012-12-23 08:13 EST by Gary Kotton
Modified: 2016-04-26 15:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-cmd2-0.6.4-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-21 15:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1051507 None None None Never

  None (edit)
Description Gary Kotton 2012-12-23 08:13:38 EST
Description of problem:
When invoking a client call get the following:

[root@gkotton-rhel64-1 ~]# quantum port-list
which: no gedit in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
which: no kate in (/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
+--------------------------------------+------+-------------------+---------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                       |
+--------------------------------------+------+-------------------+---------------------------------------------------------------------------------+
| a6f95c07-8c04-4065-a918-b5ee03e5a75e |      | fa:16:3e:31:f0:c5 | {"subnet_id": "f96e8b04-cc6b-477b-8467-ab5880c5652d", "ip_address": "10.0.0.2"} |
+--------------------------------------+------+-------------------+---------------------------------------------------------------------------------+


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Gary Kotton 2013-01-03 14:52:12 EST
Export editor variable
Comment 3 Gary Kotton 2013-01-07 11:02:46 EST
From upstream:
https://bugs.launchpad.net/quantum/+bug/1051507/comments/3
Comment 4 Alan Pevec 2013-01-07 12:48:30 EST
This should be patched out in cmd2, lines 419-425:
http://hg.assembla.com/python-cmd2/file/9e0fd9da25c6/cmd2.py#l418
Comment 7 Martin Magr 2013-01-29 08:03:02 EST
Because upstream seems to be dead, I've forked cmd2 to github and created patch [1]. Are you guys OK with the solution? Should I build python-cmd2 for Fedora and RHOS now?

[1] https://github.com/paramite/python-cmd2/commit/3e10ae189e2ccf7fcdaaa1aaebfe4d0293a8bb6c
Comment 8 Alan Pevec 2013-01-30 11:21:22 EST
(In reply to comment #7)
> Because upstream seems to be dead, I've forked cmd2 to github and created
> patch [1]. Are you guys OK with the solution? Should I build python-cmd2 for
> Fedora and RHOS now?
> 
> [1]
> https://github.com/paramite/python-cmd2/commit/
> 3e10ae189e2ccf7fcdaaa1aaebfe4d0293a8bb6c

Please check with Ralph who owns it in Fedora.
Comment 9 Ralph Bean 2013-01-30 12:45:14 EST
I'm fine with integrating the patch in Fedora but please send the patch upstream and provide some link to that in the spec file.

It looks like they don't have a bug tracker.  Maybe you could post a note in their "stream" and link to that [1].

[1] - https://www.assembla.com/spaces/python-cmd2/stream
Comment 10 Martin Magr 2013-02-01 05:14:54 EST
I've created issue in Bitbucket, where "active" development was moved according to project wiki on Assembla [1].

[1] https://www.assembla.com/spaces/python-cmd2/wiki
Comment 13 Perry Myers 2013-02-15 09:22:30 EST
*** Bug 910858 has been marked as a duplicate of this bug. ***
Comment 14 Ofer Blaut 2013-02-17 07:07:11 EST
Issue still apear,

python-quantumclient-2.1.10-3.el6ost.noarch
python-cmd2-0.6.4-5.el6ost.noarch


root@puma34 ~(keystone_admin)]$ quantum help
which: no gedit in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
which: no kate in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
/usr/bin/vim
/bin/vi
which: no emacs in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
/bin/nano
which: no pico in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
usage: quantum help [-h] [cmd [cmd ...]]

print detailed help for another command

positional arguments:
  cmd         name of the command

optional arguments:
  -h, --help  show this help message and exit
[root@puma34 ~(keystone_admin)]$ quantum --help
which: no gedit in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
which: no kate in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
/usr/bin/vim
/bin/vi
which: no emacs in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
/bin/nano
which: no pico in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
usage: quantum [--version] [-v] [-q] [-h] [--debug]
               [--os-auth-strategy <auth-strategy>] [--os-auth-url <auth-url>]
               [--os-tenant-name <auth-tenant-name>]
               [--os-username <auth-username>] [--os-password <auth-password>]
               [--os-region-name <auth-region-name>] [--os-token <token>]
               [--os-url <url>]

Command-line interface to the OpenStack Network APIs
Comment 17 Ofer Blaut 2013-03-05 14:47:46 EST
checked on python-cmd2-0.6.4-6.el6ost.noarch

Works
Comment 19 errata-xmlrpc 2013-03-21 15:04:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0672.html

Note You need to log in before you can comment on or make changes to this bug.