Bug 889797 - Error "MAC address already in use" if adding network fails for same reason when using specific MAC address
Error "MAC address already in use" if adding network fails for same reason w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.2.0
Assigned To: lpeer
Meni Yakove
network
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-23 10:47 EST by Meni Yakove
Modified: 2016-02-10 14:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (2.60 MB, text/x-log)
2012-12-23 10:47 EST, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2012-12-23 10:47:14 EST
Created attachment 668063 [details]
engine.log

Description of problem:
When adding network with specific MAC address and it fails, this MAC cannot be used again.

Version-Release number of selected component (if applicable):
rhevm-3.1.0-36.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create network (vmnet1) on the cluster (Do not attach the network to the host)
2. Create VM and add the network vmnet1 with MAC 11:22:33:44:55:66 > the operation should fail.
3. Add rhevm network to the VM with MAC 11:22:33:44:55:66.
  
Actual results:
Add rhevm network to VM fail with error  "MAC address already in use"

Expected results:
Network rhevm should be added to the VM




https://bugzilla.redhat.com/show_bug.cgi?id=842317
Comment 1 lpeer 2012-12-24 07:30:10 EST
After talking to Meni adding the missing details -

- step 2 fails because the VM was running and he used hotplug.

BZ 842317 is not about hot plug so I'm not sure this is regression.

Meni - can you please reproduce the scenario from bug 842317 see if this bug is indeed a regression.
Comment 2 Meni Yakove 2012-12-24 07:42:49 EST
This BZ in not related to bug 842317. (This BZ related to hot-plug)
Comment 3 Muli Salem 2013-01-03 06:06:31 EST
Proposed fix in:

http://gerrit.ovirt.org/#/c/10604/
Comment 4 Meni Yakove 2013-01-07 04:19:45 EST
Verified on rhevm-3.2.0-4.el6ev.noarch.

Can add NIC to vm with same MAC after adding NIC to VM failed.
Comment 6 Itamar Heim 2013-06-11 05:01:22 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:01:22 EDT
3.2 has been released
Comment 8 Itamar Heim 2013-06-11 05:01:23 EDT
3.2 has been released
Comment 9 Itamar Heim 2013-06-11 05:02:34 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 05:31:51 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.