Bug 88991 - xscreensaver-demo segfaults when clicking any buttons
xscreensaver-demo segfaults when clicking any buttons
Status: CLOSED DUPLICATE of bug 85205
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-16 01:38 EDT by Patrick Beeson
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick Beeson 2003-04-16 01:38:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I open screensaver from the control center and tried click Advanced to set up
Power info but the window disappears.  The same thing happens if you try to
choose any screensaver except the default Blank Screen.

I ran xscreensaver-demo and whne I click either of these, it seg faults.

This didn't happen in 8, only after upgrading from 8 to 9.  I got the
xscreensaver source and ran its ./configure which checks library and include
info, some things it wanted weren't installed so I stalled a bunch of
gth2-devel, libglide2, etc.  That didn't help.

[pbeeson@reverie pbeeson]$ gdb xscreensaver-demo
GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)...
(gdb) r
Starting program: /usr/X11R6/bin/xscreensaver-demo
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x42074bfe in malloc_consolidate () from /lib/tls/libc.so.6
(gdb) 


Version-Release number of selected component (if applicable):
xscreensaver-4.07-2

How reproducible:
Always

Steps to Reproduce:
1. run xscreensaver-demo
2.  click Advanced tab

    

Actual Results:  segmentation fault

Expected Results:  i think you know.

Additional info:
Comment 1 Bill Nottingham 2003-04-16 01:41:12 EDT

*** This bug has been marked as a duplicate of 85205 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.