Bug 889912 - WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x240/0x250()
WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x240/0x250()
Status: CLOSED DUPLICATE of bug 715137
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-23 21:00 EST by Alex Lang
Modified: 2013-01-03 11:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-03 11:36:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Complete ABRT oops file (2.05 KB, application/x-gzip)
2012-12-23 21:00 EST, Alex Lang
no flags Details

  None (edit)
Description Alex Lang 2012-12-23 21:00:49 EST
Created attachment 668254 [details]
Complete ABRT oops file

Description of problem:
During heavy ethernet r8169 activity, ethernet hangs with "summary" error message.

Motherboard: Sabertooth 990FX R2.0
Ethernet: Realtek 8111f
CPU: AMD FX 8120 (8 core)


Version-Release number of selected component (if applicable):
Kernel: 3.6.10-2.fc17.x86_64
Backtrace:
WARNING: at net/sched/sch_generic.c:255 dev_watchdog+0x240/0x250()
Hardware name: To be filled by O.E.M.
NETDEV WATCHDOG: em1 (r8169): transmit queue 0 timed out
Modules linked in: ip6table_filter ip6_tables ebtable_nat ebtables nfsv4 auth_rpcgss nfs dns_resolver fscache ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack xt_CHECKSUM lockd sunrpc iptable_mangle bridge stp llc bnep bluetooth it87 hwmon_vid be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi binfmt_misc snd_hda_codec_realtek eeepc_wmi asus_wmi sparse_keymap rfkill edac_core sp5100_tco edac_mce_amd snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd fam15h_power soundcore k10temp r8169 mii i2c_piix4 microcode vhost_net tun macvtap macvlan kvm_amd kvm uinput crc32c_intel ghash_clmulni_intel usb_storage nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
Pid: 0, comm: swapper/5 Not tainted 3.6.10-2.fc17.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff8105c8ef>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff8105c9e6>] warn_slowpath_fmt+0x46/0x50
 [<ffffffff8152f5e0>] dev_watchdog+0x240/0x250
 [<ffffffff8152f3a0>] ? dev_deactivate_queue.constprop.30+0x80/0x80
 [<ffffffff8106d44e>] run_timer_softirq+0x14e/0x350
 [<ffffffff810654c0>] __do_softirq+0xd0/0x210
 [<ffffffff8101b933>] ? native_sched_clock+0x13/0x80
 [<ffffffff8162827c>] call_softirq+0x1c/0x30
 [<ffffffff81016205>] do_softirq+0x75/0xb0
 [<ffffffff810658b5>] irq_exit+0xb5/0xc0
 [<ffffffff81628bbe>] smp_apic_timer_interrupt+0x6e/0x99
 [<ffffffff81627b8a>] apic_timer_interrupt+0x6a/0x70
 <EOI>  [<ffffffff8108488d>] ? __hrtimer_start_range_ns+0x1bd/0x400
 [<ffffffff81361e5f>] ? arch_local_irq_enable+0x8/0xd
 [<ffffffff81094a3e>] ? sched_clock_idle_wakeup_event+0x1e/0x20
 [<ffffffff81362750>] acpi_idle_enter_simple+0xcd/0x107
 [<ffffffff814cbc29>] cpuidle_enter+0x19/0x20
 [<ffffffff814cc2b9>] cpuidle_idle_call+0xa9/0x250
 [<ffffffff8101d52f>] cpu_idle+0xaf/0x120
 [<ffffffff8160dcb9>] start_secondary+0x23e/0x240



How reproducible: Easily reproducable


Steps to Reproduce:
1.Just filezilla a large file to the failing system
  
Actual results:


Expected results:


Additional info:
Comment 1 Alex Lang 2012-12-29 20:04:09 EST
Thinking this was a problem with either the Realtek driver or hardware, I tried an Intel PCIx LAN card and driver. No issues. 

Therefore, I suspect that this is a hardware issue with the onboard RealTek ethernet driver.
Comment 2 Josh Boyer 2013-01-03 11:36:28 EST

*** This bug has been marked as a duplicate of bug 715137 ***

Note You need to log in before you can comment on or make changes to this bug.