Bug 890018 - 'info qtree' outputs are different between "rhel6.1 host" and "rhel6.4 host with -M rhel6.1.0" (default parameters)
'info qtree' outputs are different between "rhel6.1 host" and "rhel6.4 host w...
Status: CLOSED DUPLICATE of bug 889995
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 06:01 EST by Qunfang Zhang
Modified: 2013-01-03 23:42 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-26 12:07:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'info qtree' output on rhel6.1 host with default paramters (11.61 KB, application/vnd.oasis.opendocument.text)
2012-12-24 06:02 EST, Qunfang Zhang
no flags Details
'info qtree' output on rhel6.4 host (-M rhel6.1.0) with default paramters (11.66 KB, application/vnd.oasis.opendocument.text)
2012-12-24 06:02 EST, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2012-12-24 06:01:24 EST
Description of problem:
Similar with bug 889995 but create separate issue to track -M rhel6.1.0 machine type on rhel6.4 host.

Lots of properties that doesn't exist on  rhel6.1 host, appears on rhel6.4 host. Details please check the steps. qemu should set the device state and property according to machine type.

Version-Release number of selected component (if applicable):
RHEL6.4 host:
kernel2.6.32-348.el6.x86_64
qemu-kvm-0.12.1.2-2.346.el6.x86_64

RHEL6.1-z host:
kernel-2.6.32-131.36.1.el6.x86_64
qemu-kvm-0.12.1.2-2.160.el6_1.9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start a command line on rhel6.1-z host.
# /usr/libexec/qemu-kvm  -monitor stdio 

2. On rhel6.1-z host:
(qemu)info qtree

3. Start a command line on rhel6.4 host:
# /usr/libexec/qemu-kvm -M rhel6.1.0 -monitor stdio 

4. On rhel6.4 host:
(qemu)info qtree

5. Compare the output in step 2 and step 4.

  
Actual results:
Lots of properties that doesn't exist on  rhel6.1 host, appears on rhel6.4 host.
Please check the additional info below.

Expected results:
Qemu should get device state and property according to machine type.

Additional info:

(a)"dev: PIIX4_PM", rhel6.4 host has the following properties while rhel6.1 has not.

dev-prop: disable_s3 = 1 
dev-prop: disable_s4 = 1 
dev-prop: s4_val = 2 
bus-prop: multifunction = off

(b)"bus-prop: multifunction = off" are showing up in the following devices on rhel6.4 host with -M rhel6.1.0, while it doesn't exist on rhel6.0 host.
dev: piix3-ide
dev: rtl8139
dev: cirrus-vga
dev: i440FX


(c) "dev: ide-drive" under "dev: piix3-ide", following properties are showing up on rhel6.4 host while not exist on rhel6.1 host.
 
dev-prop: discard_granularity = 0
dev-prop: wwn = 0x0

(d) "bus-prop: multifunction = on" is showing up in  "dev: PIIX3" properties list on rhel6.4 host with -M rhel6.1.0 while not exist on rhel6.1 host.

(e) "dev-prop: migrate_dir = 0" is showing up in "dev: isa-fdc" on rhel6.4 host with -M rhel6.1.0, while not exist on rhel6.1.0 host.

(f) "dev-prop: wakeup = 0" is showing up in "dev: isa-serial" on rhel6.4 host with -M rhel6.1.0, while not exist on rhel6.1.0 host.
Comment 1 Qunfang Zhang 2012-12-24 06:02:20 EST
Created attachment 668435 [details]
'info qtree' output on rhel6.1 host with default paramters
Comment 2 Qunfang Zhang 2012-12-24 06:02:48 EST
Created attachment 668436 [details]
'info qtree' output on rhel6.4 host (-M rhel6.1.0) with default paramters
Comment 3 Eduardo Habkost 2012-12-26 08:19:03 EST
Copying comment added to bug 889995:

Having new property exposed on the newer qemu versions is completely expected. What can't change is the guest-visible side: the guest-visible state and guest-visible behavior can't change when using the older machine-types.

Auditing every single property will consume some time and will require help from people with experience in each part of the QEMU code. I don't believe we should make this a blocker bug as this isn't even a real bug, unless we find an actual issue during the audit.
Comment 4 Eduardo Habkost 2012-12-26 12:07:16 EST
Unifying bugs. See bug 889995 comment #8.

*** This bug has been marked as a duplicate of bug 889995 ***

Note You need to log in before you can comment on or make changes to this bug.