Bug 890027 - virt-sysprep: Setting hostname, domain name and pretty name on Fedora 18 correctly
virt-sysprep: Setting hostname, domain name and pretty name on Fedora 18 corr...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 07:25 EST by Richard W.M. Jones
Modified: 2013-05-21 09:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 09:02:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hostnamectl.diff (86.48 KB, patch)
2012-12-24 07:25 EST, Richard W.M. Jones
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2012-12-24 07:25:57 EST
Created attachment 668479 [details]
hostnamectl.diff

Description of problem:

virt-sysprep cannot set the hostname on Fedora 18, since
Fedora 18 introduced a stupidly over-complicated way to set
the hostname.

Version-Release number of selected component (if applicable):

libguestfs 1.20

How reproducible:

100%

Additional info:

I ran the 'hostnamectl' command on a snapshot and diff'd the
two images to find out what it was doing.  The diff is attached,
but note that it contains a lot of extraneous changes because
I rebooted the machine in between.
Comment 1 Paolo Bonzini 2013-02-07 09:59:15 EST
You should use noatime to get a relevant diff.

Looking at actual mtime changes and ignoring changes to /tmp, the affected files are hostname (for the "static" hostname), machine-info (for the "pretty" hostname) and resolv.conf (for the domain name).
Comment 2 Richard W.M. Jones 2013-05-21 09:02:29 EDT
Fixed in:
0daa83cc9116a537cf154088a5a47c5c43ee6444
d2abdddf61c7bd0c6fc79dd83aa4332e213dc7ba

Note You need to log in before you can comment on or make changes to this bug.