This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890032 - vdsm: sanlock is configured as lock_manager in qemu.conf
vdsm: sanlock is configured as lock_manager in qemu.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Federico Simoncelli
Dafna Ron
storage
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-24 08:26 EST by Dafna Ron
Modified: 2016-02-10 13:13 EST (History)
9 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
logs (169.08 KB, application/x-gzip)
2012-12-24 08:26 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-12-24 08:26:16 EST
Created attachment 668485 [details]
logs

Description of problem:

I was unable to run a vm (looks like a spice issue) but the error was that we cannot obtain lock from sanlock. 
looking at qemu.conf I noticed that lock_manager="sanlock" is not disabled as it was in rhel6.3.

Version-Release number of selected component (if applicable):

fs1
vdsm-4.10.2-1.0.el6.x86_64
libvirt-0.10.2-12.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.295.el6_3.10.x86_64

How reproducible:

100%

Steps to Reproduce:
1. install a host with 6.4 OS
2. vim /etc/libvirt/qemu.conf
3. search for lock_manager
  
Actual results:

lock_manager="sanlock" is not disabled

Expected results:

when we install the host we configure lock_manager="sanlock" to be disabled (we did in 6.3)

Additional info: logs
Comment 1 RHEL Product and Program Management 2012-12-28 01:48:15 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Dafna Ron 2013-02-06 12:00:14 EST
verified on vdsm-4.10.2-5.0.el6ev.x86_64

#lock_manager = "sanlock"
Comment 5 Itamar Heim 2013-06-11 05:27:39 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:31:16 EDT
3.2 has been released
Comment 7 Itamar Heim 2013-06-11 05:47:02 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.