Bug 890033 - qemu-kvm-rhev: vm with spice monitors crashes with no alert when we run it on rhel6.4 with qemu-kvm-rhev from rhel6.3
Summary: qemu-kvm-rhev: vm with spice monitors crashes with no alert when we run it on...
Keywords:
Status: CLOSED DUPLICATE of bug 890048
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server
Version: 6.4
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Uri Lublin
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-24 13:39 UTC by Dafna Ron
Modified: 2013-01-08 16:07 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-08 16:07:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
logs (358.96 KB, application/x-gzip)
2012-12-24 13:39 UTC, Dafna Ron
no flags Details
core log (596.20 KB, application/x-xz)
2012-12-24 16:12 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2012-12-24 13:39:14 UTC
Created attachment 668486 [details]
logs

Description of problem:

I installed a host with rhel6.4 in rhevm (sf1 build) and ran a vm with spice. 
vm crashes with libvirt error: Error on monitor internal error End of file from monitor

Version-Release number of selected component (if applicable):

sf1
vdsm-4.10.2-1.0.el6.x86_64
libvirt-0.10.2-12.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.295.el6_3.10.x86_64

How reproducible:

100%

Steps to Reproduce:
1. install rhevm (build sf1) with rhel6.4 host
2. create iscsi domain
3. create a vm with spice monitor -> run vm 
4. edit vm to run with vnc monitor -> run vm

  
Actual results:

we cannot run a vm with spice. 
vm can run with vnc

Expected results:

we should be able to run a vm with spice


Additional info: full logs attached 


hread-3152::ERROR::2012-12-24 15:25:43,243::vm::680::vm.Vm::(_startUnderlyingVm) vmId=`3812d92a-70b5-4202-a780-91136642eed0`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 642, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/libvirtvm.py", line 1449, in _run
    self._domDependentInit()
  File "/usr/share/vdsm/libvirtvm.py", line 1342, in _domDependentInit
    self._guestCpuRunning = (self._dom.info()[0] ==
  File "/usr/share/vdsm/libvirtvm.py", line 515, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 83, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1855, in info
    if ret is None: raise libvirtError ('virDomainGetInfo() failed', dom=self)
libvirtError: Domain not found: no domain with matching uuid '3812d92a-70b5-4202-a780-91136642eed0'
Thread-3158::DEBUG::2012-12-24 15:25:43,259::libvirtvm::320::vm.Vm::(handleStatsException) vmId=`3812d92a-70b5-4202-a780-91136642eed0`::VM not found, moving to Down
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/vdsm/utils.py", line 412, in collect
    statsFunction()
  File "/usr/lib64/python2.6/site-packages/vdsm/utils.py", line 287, in __call__
    retValue = self._function(*args, **kwargs)
  File "/usr/share/vdsm/libvirtvm.py", line 147, in _sampleDisk
    diskSamples[vmDrive.name] = self._vm._dom.blockStats(vmDrive.name)
  File "/usr/share/vdsm/libvirtvm.py", line 515, in f
    ret = attr(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 83, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1820, in blockStats
    if ret is None: raise libvirtError ('virDomainBlockStats() failed', dom=self)
libvirtError: Domain not found: no domain with matching uuid '3812d92a-70b5-4202-a780-91136642eed0'
libvirtEventLoop::DEBUG::2012-12-24 15:25:43,269::utils::353::vm.Vm::(stop) vmId=`3812d92a-70b5-4202-a780-91136642eed0`::Stop statistics collection
libvirtEventLoop::DEBUG::2012-12-24 15:25:43,270::vmChannels::152::vds::(unregister) Delete fileno 21 from listener.
libvirtEventLoop::DEBUG::2012-12-24 15:25:43,272::misc::83::Storage.Misc.excCmd::(<lambda>) '/usr/bin/sudo -n /sbin/service ksmtuned retune' (cwd None)
Thread-3152::DEBUG::2012-12-24 15:25:43,285::vm::1031::vm.Vm::(setDownStatus) vmId=`3812d92a-70b5-4202-a780-91136642eed0`::Changed state to Down: Domain not found: no domain with matching uuid '3812d92a-70b5-4202-a780-91136642eed0'
Thread-3152::DEBUG::2012-12-24 15:25:43,287::vmChannels::152::vds::(unregister) Delete fileno 21 from listener.

Comment 1 Dafna Ron 2012-12-24 16:09:22 UTC
after further tests, the qemu installed was from 6.3. 
for some reason the vms with spice crashed on qemu from rhel6.3 while the vms with vnc managed to run. 
I am moving this bug to qemu and changing headline so that we will issue a correct alert instead of crashing the vm and perhaps see why vnc vms can run while spice one crash. 
I'm also attaching a core log

Comment 2 Dafna Ron 2012-12-24 16:12:35 UTC
Created attachment 668532 [details]
core log

Comment 3 juzhang 2012-12-25 02:45:08 UTC
(In reply to comment #0)
> Created attachment 668486 [details]
> logs
> 
> Description of problem:
> 
> I installed a host with rhel6.4 in rhevm (sf1 build) and ran a vm with
> spice. 
> vm crashes with libvirt error: Error on monitor internal error End of file
> from monitor
> 
> Version-Release number of selected component (if applicable):
> 
> sf1
> vdsm-4.10.2-1.0.el6.x86_64
> libvirt-0.10.2-12.el6.x86_64
> qemu-kvm-rhev-0.12.1.2-2.295.el6_3.10.x86_64
> 
Hi, Dafna

I'm KVM QE, I plan to reproduce this issue by using qemu-kvm directly.The libvirt version is rhel6.4, however, the qemu-kvm-rhev version is rhel6.3.z., I'm not sure the combination is right. Would you please provide spice-server version as well?
> How reproducible:
> 
> 100%
> 
> Steps to Reproduce:
> 1. install rhevm (build sf1) with rhel6.4 host
The host which the guest stay is rhel6.4 or rhel6.3.z?

Comment 4 juzhang 2012-12-25 02:49:01 UTC
FYI
Bug 883654 - qemu crashes when rebooting the guest: SpiceWorker-ERROR **: red_worker.c:4797:qxl_process_cursor: invalid cursor command 235

Comment 5 Dafna Ron 2012-12-25 08:32:15 UTC
yes, the rhel6.4 host was installed with qemu for rhel6.3z - this happened when the rhel4 repo did not have the qemu-kvm-rhev package but only qemu-kvm (there are several bugs here - not related to qemu and already opened). 
however, since in this configuration, the vm with spice crashes while the vm with vnc does not the user might not know what the issue is. 
a nice exit message instead of a crash would be better if configuration is not supported.

Comment 6 juzhang 2012-12-25 09:03:10 UTC
(In reply to comment #5)
> yes, the rhel6.4 host was installed with qemu for rhel6.3z - this happened
> when the rhel4 repo did not have the qemu-kvm-rhev package but only qemu-kvm
> (there are several bugs here - not related to qemu and already opened). 
> however, since in this configuration, the vm with spice crashes while the vm
> with vnc does not the user might not know what the issue is. 
> a nice exit message instead of a crash would be better if configuration is
> not supported.

Hi, Dafna

Can you paste spice-server version?

Comment 7 Dafna Ron 2012-12-25 09:26:15 UTC
sure
spice-server-0.12.0-8.el6.x86_64

Comment 10 FuXiangChun 2012-12-25 15:48:03 UTC
Maybe spice-sever version lead to this issue(it maybe be a direct cause"/usr/libexec/qemu-kvm: /usr/lib64/libjpeg.so.62: no version information available (required by /usr/lib64/libspice-server.so.1)"). 

install these package:
# rpm -qa|grep spice
spice-server-0.12.0-8.el6.x86_64
# rpm -qa|grep libvirt
libvirt-0.10.2-12.el6.x86_64

rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.295.el6_3.10.x86_64

1.boot guest with spice

/usr/libexec/qemu-kvm -name BLABLA -M rhel6.3.0 -cpu host -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -uuid 3812d92a-70b5-4202-a780-91136642eed0 -nodefconfig -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/BLABLA.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-12-24T01:25:42,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=qcow2,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/home/rhel6u4.qcow2,if=none,id=drive-virtio-disk0,format=raw,serial=8bfffaa8-5637-4404-90e5-ed18069b05e7,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:23:61:65,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/BLABLA.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/BLABLA.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.re -spice port=5911,disable-ticketing -vga qxl
/usr/libexec/qemu-kvm: /usr/lib64/libjpeg.so.62: no version information available (required by /usr/lib64/libspice-server.so.1)
Segmentation fault (core dumped)

(gdb) bt
#0  0x00007ffff7fb469f in ?? ()
#1  0x00007fffb81d80a0 in ?? ()
#2  0x00007fffb80008c0 in ?? ()
#3  0x00007ffff5f78068 in ?? () from /usr/lib64/libspice-server.so.1
#4  0x00007ffff5f78930 in ?? () from /usr/lib64/libspice-server.so.1
#5  0x00007ffff5f6cca7 in ?? () from /usr/lib64/libspice-server.so.1
#6  0x00007ffff5f8d9ce in ?? () from /usr/lib64/libspice-server.so.1
#7  0x00007ffff77497f1 in start_thread () from /lib64/libpthread.so.0
#8  0x00007ffff57f970d in clone () from /lib64/libc.so.6

2.boot guest with vnc, qemu works nomally

/usr/libexec/qemu-kvm -name BLABLA -M rhel6.3.0 -cpu host -enable-kvm -m 512 -smp 1,sockets=1,cores=1,threads=1 -uuid 3812d92a-70b5-4202-a780-91136642eed0 -nodefconfig -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/BLABLA.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-12-24T01:25:42,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/home/rhel6u4.qcow2,if=none,id=drive-virtio-disk0,format=raw,serial=8bfffaa8-5637-4404-90e5-ed18069b05e7,cache=none,werror=stop,rerror=stop,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:23:61:65,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/BLABLA.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/BLABLA.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.re -vnc :1
/usr/libexec/qemu-kvm: /usr/lib64/libjpeg.so.62: no version information available (required by /usr/lib64/libspice-server.so.1)

Comment 11 Yonit Halperin 2013-01-08 16:07:13 UTC

*** This bug has been marked as a duplicate of bug 890048 ***


Note You need to log in before you can comment on or make changes to this bug.