Bug 890050 - vdsm: cannot migrate vms between a 6.3 host and a 6.4 host with error 'migration job: unexpectedly failed'
vdsm: cannot migrate vms between a 6.3 host and a 6.4 host with error 'migrat...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Martin Betak
Haim
infra,virt
: Regression
Depends On: 869981
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 11:52 EST by Dafna Ron
Modified: 2014-01-12 19:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 07:32:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.26 MB, application/x-gzip)
2012-12-24 11:52 EST, Dafna Ron
no flags Details
Log from migration using virsh (8.56 KB, text/plain)
2013-01-17 05:58 EST, Martin Betak
no flags Details

  None (edit)
Description Dafna Ron 2012-12-24 11:52:42 EST
Created attachment 668535 [details]
logs

Description of problem:

In sf1, I have a cluster which is 3.1 with 1 host that is rhel6.3 and one host which is 6.4. 
I cannot migrate a vm between these two hosts with the same error: migration job: unexpectedly failed

Version-Release number of selected component (if applicable):

sf1
rhel6.3 host: 
==============

vdsm-4.9.6-44.2.el6_3.x86_64
libvirt-0.9.10-21.el6_3.7.x86_64
qemu-kvm-rhev-0.12.1.2-2.295.el6_3.10.x86_64

6.4 host:
===========

vdsm-4.10.2-1.0.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.337.el6.x86_64
libvirt-0.10.2-12.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. install a 6.3 host and a 6.4 host in the same 3.1 cluster
2. run a vm on any of the hosts
3. migrate the vm
  
Actual results:

we fail to migrate the vm

Expected results:

since we will need to migrate vms during upgrade we should not fail. 

Additional info: logs from both hosts
Comment 1 RHEL Product and Program Management 2012-12-28 01:48:10 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Martin Betak 2013-01-17 05:58:22 EST
Created attachment 680128 [details]
Log from migration using virsh

Note You need to log in before you can comment on or make changes to this bug.