Bug 890080 - [abrt] libreoffice-core-3.5.7.2-7.fc17: dereference NULL pSwView in SwXTextDocument::getRendererCount
[abrt] libreoffice-core-3.5.7.2-7.fc17: dereference NULL pSwView in SwXTextDo...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:327dcd563f63f46ac10d507b899...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-24 20:53 EST by David Ford
Modified: 2013-02-01 23:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 23:37:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (5.08 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: environ (1.84 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: backtrace (227.65 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: smolt_data (2.63 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: cgroup (128 bytes, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: executable (42 bytes, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: maps (119.83 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: dso_list (27.39 KB, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: proc_pid_status (933 bytes, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: open_fds (344 bytes, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details
File: var_log_messages (179 bytes, text/plain)
2012-12-24 20:53 EST, David Ford
no flags Details

  None (edit)
Description David Ford 2012-12-24 20:53:22 EST
Version-Release number of selected component:
libreoffice-core-3.5.7.2-7.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 3
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: os::die
kernel:         3.6.10-2.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 os::die at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1597
: #3 VMError::report_and_die at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1022
: #4 crash_handler at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/vmError_linux.cpp:106
: #6 ??
: #7 os::abort at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1578
: #8 VMError::report_and_die at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1018
: #9 JVM_handle_linux_signal at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:528
: #11 SwView::RecheckBrowseMode at /usr/src/debug/libreoffice-3.5.7.2/solver/unxlngx6.pro/inc/svl/eitem.hxx:51
: #12 SwXTextDocument::getRendererCount at /usr/src/debug/libreoffice-3.5.7.2/sw/source/ui/uno/unotxdoc.cxx:2564
: #13 SfxPrinterController::getPageCount at /usr/src/debug/libreoffice-3.5.7.2/sfx2/source/view/viewprn.cxx:241

Potential duplicate bug: 706076
Comment 1 David Ford 2012-12-24 20:53:27 EST
Created attachment 668642 [details]
File: core_backtrace
Comment 2 David Ford 2012-12-24 20:53:29 EST
Created attachment 668643 [details]
File: environ
Comment 3 David Ford 2012-12-24 20:53:37 EST
Created attachment 668644 [details]
File: backtrace
Comment 4 David Ford 2012-12-24 20:53:39 EST
Created attachment 668645 [details]
File: limits
Comment 5 David Ford 2012-12-24 20:53:40 EST
Created attachment 668646 [details]
File: smolt_data
Comment 6 David Ford 2012-12-24 20:53:42 EST
Created attachment 668647 [details]
File: cgroup
Comment 7 David Ford 2012-12-24 20:53:44 EST
Created attachment 668648 [details]
File: executable
Comment 8 David Ford 2012-12-24 20:53:50 EST
Created attachment 668649 [details]
File: maps
Comment 9 David Ford 2012-12-24 20:53:52 EST
Created attachment 668650 [details]
File: dso_list
Comment 10 David Ford 2012-12-24 20:53:54 EST
Created attachment 668651 [details]
File: proc_pid_status
Comment 11 David Ford 2012-12-24 20:53:56 EST
Created attachment 668652 [details]
File: open_fds
Comment 12 David Ford 2012-12-24 20:53:59 EST
Created attachment 668653 [details]
File: var_log_messages
Comment 13 Michael Stahl 2013-01-04 18:48:53 EST
crash because pSwView is 0 in "pSwView->RecheckBrowseMode();"

apparently this pSwView was introduced in OOo 3.4 in commit 2f9f480b22f2fff59d9c48b4b46706c3d5223e66
so it's likely this crash is a regression.

pSwView is checked for 0 in every use except the one the one that
causes this crash here, so i'll assume it's a simple oversight.

fixed upstream master in commit 1c52268a5bc6d79c6ee1344e4e341c7e3820d4e0
and backported to 4.0 branch and proposed for 3.6 branch;
added to f17 package, should be in next update for that.
Comment 14 Fedora Update System 2013-01-21 05:33:52 EST
libreoffice-3.5.7.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-8.fc17
Comment 15 Fedora Update System 2013-01-22 21:04:12 EST
Package libreoffice-3.5.7.2-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1280/libreoffice-3.5.7.2-8.fc17
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-01-23 01:39:18 EST
libreoffice-3.5.7.2-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-9.fc17
Comment 17 Fedora Update System 2013-02-01 23:37:25 EST
libreoffice-3.5.7.2-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.