Bug 890112 - 'info qtree' outputs are different between "rhel6.3 host" and "rhel6.4 host with -M rhel6.3.0" (default parameters)
'info qtree' outputs are different between "rhel6.3 host" and "rhel6.4 host w...
Status: CLOSED DUPLICATE of bug 889995
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 02:47 EST by Qunfang Zhang
Modified: 2013-01-03 23:42 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-26 12:07:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'info qtree' output on rhel6.3 host with default paramters (11.49 KB, application/vnd.oasis.opendocument.text)
2012-12-25 03:06 EST, Qunfang Zhang
no flags Details
'info qtree' output on rhel6.4 host (-M rhel6.3.0) with default paramters (11.58 KB, application/vnd.oasis.opendocument.text)
2012-12-25 03:06 EST, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2012-12-25 02:47:40 EST
Description of problem:
Lots of properties that doesn't exist on  rhel6.3 host, appears on rhel6.4 host when boot with -M rhel6.3.0. Details please check the steps.

Version-Release number of selected component (if applicable):
RHEL6.4 host:
kernel2.6.32-348.el6.x86_64
qemu-kvm-0.12.1.2-2.346.el6.x86_64

RHEL6.3-z host:
kernel-2.6.32-279.19.1.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6_3.10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start a command line on rhel6.3-z host.
# /usr/libexec/qemu-kvm  -monitor stdio 

2. On rhel6.3-z host:
(qemu)info qtree

3. Start a command line on rhel6.4 host:
# /usr/libexec/qemu-kvm -M rhel6.3.0 -monitor stdio 

4. On rhel6.4 host:
(qemu)info qtree

5. Compare the output in step 2 and step 4.
  
Actual results:
Lots of properties that doesn't exist on  rhel6.3 host, appears on rhel6.4 host when boot with -M rhel6.3.0. Please check the additional info.

Expected results:
The "info qtree" output should be the same on the two hosts.

Additional info:

(a)  "dev: PIIX4_PM", rhel6.4 host with -M rhel6.2.0 has the following properties while rhel6.2 has not.
dev-prop: disable_s3 = 1 
dev-prop: disable_s4 = 1 
dev-prop: s4_val = 2 

(b) "dev: ide-drive" under "dev: piix3-ide", following property are showing up on rhel6.4 host while not exist on rhel6.2 host.

dev-prop: wwn = 0x0

(c) "dev: isa-fdc" under "dev: PIIX3",  following property are showing up on rhel6.4 host while not exist on rhel6.2 host.

dev-prop: migrate_dir = 0
Comment 2 Qunfang Zhang 2012-12-25 03:06:04 EST
Created attachment 668777 [details]
'info qtree' output on rhel6.3 host with default paramters
Comment 3 Qunfang Zhang 2012-12-25 03:06:54 EST
Created attachment 668778 [details]
'info qtree' output on rhel6.4 host (-M rhel6.3.0) with default paramters
Comment 4 Eduardo Habkost 2012-12-26 08:19:13 EST
Copying comment added to bug 889995:

Having new property exposed on the newer qemu versions is completely expected. What can't change is the guest-visible side: the guest-visible state and guest-visible behavior can't change when using the older machine-types.

Auditing every single property will consume some time and will require help from people with experience in each part of the QEMU code. I don't believe we should make this a blocker bug as this isn't even a real bug, unless we find an actual issue during the audit.
Comment 5 Eduardo Habkost 2012-12-26 12:07:32 EST
Unifying bugs. See bug 889995 comment #8.

*** This bug has been marked as a duplicate of bug 889995 ***

Note You need to log in before you can comment on or make changes to this bug.