Bug 890123 - [RFE] 'Services' tab does not show liveness of the services
[RFE] 'Services' tab does not show liveness of the services
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
medium Severity urgent
: Upstream M3
: 4.0
Assigned To: Julie Pichon
Nir Magnezi
: FutureFeature, Triaged
Depends On: 1010315
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2012-12-25 03:56 EST by Yaniv Kaul
Modified: 2016-04-26 17:16 EDT (History)
9 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-0.12b3.el6ost
Doc Type: Enhancement
Doc Text:
The 'System Info' panel in the Administrator dashboard now has two additional tabs displaying service status. The 'Compute Services' tab provides additional information on the Compute services. Details include host and current status for nova-conductor, nova-compute, and nova-cert. The 'Network Agents' tab is available when Networking is enabled, and provides data on Network Agents such as L3 and DHCP.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:53:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Compute Services (38.96 KB, image/png)
2013-10-25 09:27 EDT, Julie Pichon
no flags Details
Network Agents (38.32 KB, image/png)
2013-10-25 09:28 EDT, Julie Pichon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1198247 None None None Never
Launchpad 1204375 None None None Never
OpenStack gerrit 36024 None None None Never
OpenStack gerrit 38762 None None None Never

  None (edit)
Description Yaniv Kaul 2012-12-25 03:56:19 EST
Description of problem:
I don't think it's a Horizon bug, feel free to move component.
In the services tab, you get information about the services (I'm not sure if it's via keystone service or nova service-list - I believe keystone). 
However, there's no indication  that a service is working or not.
Here's a command line example:
[root@ykaul-os-horizon ~(keystone_admin)]$ nova service-list
ERROR: n/a (HTTP 400)
[root@ykaul-os-horizon ~(keystone_admin)]$ keystone service-list
+----------------------------------+----------+----------+----------------------------+
|                id                |   name   |   type   |        description         |
+----------------------------------+----------+----------+----------------------------+
| 4a811d58e1264df3b44348c654fc59bc | nova_ec2 |   ec2    |        EC2 Service         |
| 60f3fefe09224533a741136debaf119f |  glance  |  image   |  Openstack Image Service   |
| 95dc86c43bb745a0832e87f23dc4ff05 | keystone | identity | OpenStack Identity Service |
| a53e544c0dc643c8b27250c16cd7f7a9 |   nova   | compute  | Openstack Compute Service  |
| e873fc26c48f47d8a36166aaff89d5df |  cinder  |  volume  |       Cinder Service       |
+----------------------------------+----------+----------+----------------------------+


(My Nova API host was down).
I'd be happy to get more than 'enabled' in Horizon, to see that services are responding.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2012-12-25 04:08:39 EST
Actually, nova-manage service list does provide this:
[root@ykaul-os-nova-api1 ~(keystone_admin)]$ nova-manage service list
2012-12-25 11:06:37 DEBUG nova.utils [req-5fe32888-4add-4529-a350-c6292f76719f None None] backend <module 'nova.db.sqlalchemy.api' from '/usr/lib/python2.6/site-packages/nova/db/sqlalchemy/api.pyc'> __get_backend /usr/lib/python2.6/site-packages/nova/utils.py:502
Binary           Host                                 Zone             Status     State Updated_At
nova-scheduler   ykaul-os-nova-sched1.qa.lab.tlv.redhat.com nova             enabled    :-)   2012-12-25 09:06:31
nova-cert        ykaul-os-nova-vncproxy.qa.lab.tlv.redhat.com nova             enabled    XXX   2012-12-23 19:56:52
nova-consoleauth ykaul-os-nova-vncproxy.qa.lab.tlv.redhat.com nova             enabled    XXX   2012-12-23 19:56:55
nova-compute     rhev-a24c-01.mpc.lab.eng.bos.redhat.com nova             enabled    XXX   2012-12-25 09:15:17
nova-network     rhev-a24c-01.mpc.lab.eng.bos.redhat.com nova             enabled    XXX   2012-12-25 09:15:24


The :-) or XXX show the state, as well as FQDN of resolved IPs of the hosts - which is much more useful than what we have today in Horizon.
Comment 2 Julie Pichon 2012-12-28 06:59:12 EST
I agree that this would be very useful.

The nova-manage service list command doesn't quite provide that information, it only shows the state for the nova sub-services (so glance etc are not included). Also nova-manage is a nova administration command that requires root access and is not accessible from the client libraries that Horizon depends on.

I don't know if there is a way to do it now, although it's certainly worth investigating further. I'm not sure either which other components could help us enable such a feature: if an individual service is down it can't tell us much. Even if keystone does provide a list of services, it seems beyond its scope as an Identity service to provide state information.
Comment 3 Julie Pichon 2013-03-08 09:36:22 EST
Moving to 3.0 -- this is a feature request that will require a blueprint to be accepted upstream, and is also closer to "Managing OpenStack itself" which may be beyond the scope of Horizon. Not sure in which component such a feature would fit best, though.
Comment 5 Lon Hohberger 2013-08-01 09:40:43 EDT
Parts of this have been pushed to the upstream repository.
Comment 6 Alvaro Lopez Ortega 2013-08-07 08:22:31 EDT
Julie, could you please check out this one?
Comment 9 Omri Hochman 2013-10-13 10:47:40 EDT
Verified with : python-django-horizon-2013.2-0.13b3.el6ost.noarch
(Havana RHOS 4.0, puddle 2013-10-03.3)


From Horizion GUI View: 
-------------------------
Compute Services  Filter
Name	Host	Zone	Status	State	Updated At
nova-scheduler	cougar15.scl.lab.tlv.redhat.com	internal	enabled	up	0 minutes
nova-consoleauth	cougar15.scl.lab.tlv.redhat.com	internal	enabled	up	0 minutes
nova-conductor	cougar15.scl.lab.tlv.redhat.com	internal	enabled	up	0 minutes
nova-cert	cougar15.scl.lab.tlv.redhat.com	internal	enabled	up	0 minutes
nova-network	cougar15.scl.lab.tlv.redhat.com	internal	enabled	up	0 minutes
nova-compute	cougar15.scl.lab.tlv.redhat.com	nova	enabled	up	0 minutes

From CLI : 
----------
[root@openstack ~(keystone_admin)]# nova service-list
+------------------+---------------------------------+----------+---------+-------+----------------------------+-----------------+
| Binary           | Host                            | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+------------------+---------------------------------+----------+---------+-------+----------------------------+-----------------+
| nova-scheduler   | cougar15.scl.lab.tlv.redhat.com | internal | enabled | up    | 2013-10-13T14:45:02.000000 | None            |
| nova-consoleauth | cougar15.scl.lab.tlv.redhat.com | internal | enabled | up    | 2013-10-13T14:44:59.000000 | None            |
| nova-conductor   | cougar15.scl.lab.tlv.redhat.com | internal | enabled | up    | 2013-10-13T14:45:01.000000 | None            |
| nova-cert        | cougar15.scl.lab.tlv.redhat.com | internal | enabled | up    | 2013-10-13T14:45:00.000000 | None            |
| nova-network     | cougar15.scl.lab.tlv.redhat.com | internal | enabled | up    | 2013-10-13T14:44:59.000000 | None            |
| nova-compute     | cougar15.scl.lab.tlv.redhat.com | nova     | enabled | up    | 2013-10-13T14:45:02.000000 | None            |
+------------------+---------------------------------+----------+---------+-------+----------------------------+-----------------+
Comment 11 Julie Pichon 2013-10-25 09:26:50 EDT
Adding doc text, will also attach screenshots for clarity.
Comment 12 Julie Pichon 2013-10-25 09:27:48 EDT
Created attachment 816156 [details]
Compute Services
Comment 13 Julie Pichon 2013-10-25 09:28:35 EDT
Created attachment 816158 [details]
Network Agents
Comment 15 errata-xmlrpc 2013-12-19 18:53:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.