This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890184 - postgres support for database -quantum
postgres support for database -quantum
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
1.0 (Essex)
Unspecified Unspecified
medium Severity medium
: Upstream M3
: 5.0 (RHEL 7)
Assigned To: Terry Wilson
Ofer Blaut
: FutureFeature, Reopened, TestOnly, Triaged
Depends On:
Blocks: 816316
  Show dependency treegraph
 
Reported: 2012-12-25 10:10 EST by Perry Myers
Modified: 2016-04-26 13:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 816316
Environment:
Last Closed: 2014-04-02 08:31:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2012-12-25 10:10:06 EST
+++ This bug was initially created as a clone of Bug #816316 +++

Description of problem:
Presently upstream OpenStack primarily utilizes mysql for its database.  We'd like to expand this to include postgres in addition.  There are probably some integration issues/small problems with running Postgres w/ Essex today, and these bugs will need to be tracked and individually resolved separately.

This bug is specifically for tracking the overall support of Postgres, and as such is a TestOnly bug.

--- Additional comment from Perry Myers on 2012-04-25 15:14:39 EDT ---

Related bugs:
https://bugs.launchpad.net/glance/+bug/953159
https://bugs.launchpad.net/glance/+bugs?field.tag=postgresql
Comment 1 Terry Wilson 2013-01-03 17:32:52 EST
I've been running almost exclusively with a postgresql backend for months without any problems w/ Quantum. I've primarily tested with devstack, though, so I'll do a quick check on RHOS as well.
Comment 2 Terry Wilson 2013-01-08 17:05:16 EST
I just tested quantum net/subnet/port/router create/delete commands on RHOS with a postgresql back end and had no issues.
Comment 3 Perry Myers 2013-01-09 15:20:58 EST
It's good that it worked for you, but we also want QE to include this in their test plans and verify as part of QE runs.

So we should move this bug to ON_QA and let QE move to VERIFIED later
Comment 4 Ofer Blaut 2013-06-18 14:39:46 EDT
Since packstack doesn't support postgres  and we don't have Manuel steps to install it, I'm moving it back to ON_DEV until we have support for it
Comment 7 Nir Yechiel 2014-04-02 08:31:14 EDT
I am closing this RFE since I can't see any specific request for postgres support at this time. We will reopen this and consider QE testing if such a request will come.

-Nir

Note You need to log in before you can comment on or make changes to this bug.