Bug 890203 - [engine] Storage will remain in locked forever in case remove storage pool fail on cannot find master domain
[engine] Storage will remain in locked forever in case remove storage pool fa...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
All Linux
unspecified Severity high
: ---
: 3.1.3
Assigned To: Liron Aravot
Dafna Ron
storage
: ZStream
Depends On: 875651
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 12:53 EST by Simon Grinberg
Modified: 2016-02-10 15:59 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, manually removing a master storage domain and then attempting to remove it using the GUI would result in the storage domain appearing in a permanently 'locked' status. This was caused by the VDSM reporting "cannot find master domain". Now, the storage domain does not remain stuck in 'locked' status and can be removed correctly using the GUI.
Story Points: ---
Clone Of: 875651
Environment:
Last Closed: 2013-03-12 10:26:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 3 Dafna Ron 2013-02-11 11:51:47 EST
verified on si27
storage domian does not stay locked after we fail remove. 
we are still getting a long exception - different bug will be opened for this issue.
Comment 5 errata-xmlrpc 2013-03-12 10:26:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0557.html

Note You need to log in before you can comment on or make changes to this bug.