Bug 890206 - Transition glance API->registry interface to RPC mechanism
Transition glance API->registry interface to RPC mechanism
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Flavio Percoco
Yaniv Kaul
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-25 12:58 EST by Perry Myers
Modified: 2013-07-03 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 04:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2012-12-25 12:58:36 EST
Transition glance API->registry interface to RPC mechanism
Comment 1 Flavio Percoco 2013-03-13 04:27:27 EDT
As for Havana, Glance will migrate from an API->Registry architecture to just API. The idea is to deprecate the Registry server in favor of direct access to the database. This is being drafted / tracked in this blueprint[0].

That said, I don't think this transition will happen since it wouldn't make sense, even though, users will be able to use the silly registry implementation if they prefer it. 

[0] https://blueprints.launchpad.net/glance/+spec/registry-db-driver

Note You need to log in before you can comment on or make changes to this bug.