This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 890214 - No warning when engine starts with no mac addresses pool
No warning when engine starts with no mac addresses pool
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra network
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-25 14:06 EST by Arik
Modified: 2015-03-04 19:18 EST (History)
11 users (show)

See Also:
Fixed In Version: sf3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-31 05:33:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10518 None None None Never

  None (edit)
Description Arik 2012-12-25 14:06:57 EST
Description of problem:
When we start the engine with no MAC addresses pool in the DB (out-of-date DB), there is no message about it on startup. on debug, we found that an exception is thrown on: DbFacade.getInstance().getVmNetworkInterfaceDao().getAll() call at MacPoolManager, but no one catch it.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. start the engine with no MAC addresses pool in the DB
2.
3.
  
Actual results:
There's no log printing which reflects that the MAC address pool wasn't initialized

Expected results:
Have log message saying that the MAC addresses pool couldn't be initialized

Additional info:
Comment 1 Yair Zaslavsky 2012-12-31 05:31:33 EST
Suggested patch upstream -

http://gerrit.ovirt.org/#/c/10518/
Comment 4 Moti Asayag 2013-01-31 05:33:47 EST
Closed since this is unlikely use-case.

Note You need to log in before you can comment on or make changes to this bug.