Bug 890227 - LDAP-less routing is broken and complains about missing -T<TMPF>
Summary: LDAP-less routing is broken and complains about missing -T<TMPF>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sendmail
Version: 6.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 6.6
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 994246 1002711 1075802
TreeView+ depends on / blocked
 
Reported: 2012-12-25 22:45 UTC by Robert Scheck
Modified: 2019-07-11 07:38 UTC (History)
4 users (show)

Fixed In Version: sendmail-8.14.4-9.el6
Doc Type: Bug Fix
Doc Text:
* Prior to this update, the ldap_routing feature did not work as expected. If ldap_routing was used, sendmail reported the "-T<TMPF>" option missing, and the user was required to insert "-T<TMPF>" manually. With this update, the macro for generating configuration for ldap_routing has been fixed, and the user is no longer required to add "-T<TMPF>" manually when using ldap_routing. (BZ#890227)
Clone Of:
Environment:
Last Closed: 2015-07-22 06:24:17 UTC


Attachments (Terms of Use)
sendmail-8.14.4-ldap_routing.patch (2.68 KB, patch)
2012-12-25 23:12 UTC, Robert Scheck
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1299 normal SHIPPED_LIVE sendmail bug fix update 2015-07-20 17:53:56 UTC

Description Robert Scheck 2012-12-25 22:45:05 UTC
Description of problem:
When using LDAP-less mail routing, I noticed that m4(1) does not produce a
usable sendmail.cf file. Simply put the following into sendmail.mc:

LDAPROUTE_DOMAIN(`example.net')dnl
FEATURE(`ldap_routing', `hash -o /etc/mail/transport.db', `hash -o /etc/mail/virtusertable.db', `bounce')dnl

Afterwards try to let a new sendmail.cf produce by running m4(1).

$ make -C /etc/mail transport.db all
make: Entering directory `/etc/mail'
*** WARNING: missing -T<TMPF> in first argument of FEATURE(`ldap_routing')
*** WARNING: missing -T<TMPF> in second argument of FEATURE(`ldap_routing')
make: Leaving directory `/etc/mail'
$ 

Version-Release number of selected component (if applicable):
sendmail-8.14.4-8.el6.x86_64

How reproducible:
Everytime, see above and below.

Actual results:
LDAP-less routing is broken and thus it complains about missing -T<TMPF> all
the time. This issue is already known upstream and has been solved ages ago;
see errata section of http://www.sendmail.com/sm/open_source/download/8.14.4/
or http://www.sendmail.com/sm/open_source/download/8.14.5/?show_rs=true#RS.

Expected results:
Backported patch for sendmail-8.14.4-8.el6 and updated RPM package in RHEL 6.

Additional info:
Yes, there is the workaround to add "-T<TMPF>" yourself, however this doesn't
seem to make much sense in LDAP-less setups.

Comment 2 Robert Scheck 2012-12-25 23:12:04 UTC
Created attachment 669051 [details]
sendmail-8.14.4-ldap_routing.patch

Comment 6 Andrius Benokraitis 2013-10-07 01:34:52 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6, and will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Comment 7 Robert Scheck 2013-10-08 12:21:19 UTC
Just closing this bug report is not acceptable, especially as it is linked
with ticket 00769705 in the Red Hat customer portal. If you are lacking any
information, you also could have let us know so via an official path or via
an e-mail instead of just closing this report...reopening.

Comment 8 RHEL Product and Program Management 2013-10-14 00:06:54 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 13 Alois Mahdal 2015-04-13 07:02:01 UTC
Verified on all supported archs.  After the fix, make no longer complains about missing -T.

Comment 15 errata-xmlrpc 2015-07-22 06:24:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1299.html


Note You need to log in before you can comment on or make changes to this bug.