Bug 890324 - [ovirt-engine-backend] Can not upgrade from 3.1 to 3.2
[ovirt-engine-backend] Can not upgrade from 3.1 to 3.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Eli Mesika
Pavel Stehlik
infra
: Regression, TestBlocker
Depends On: 892532 909948
Blocks: 885369
  Show dependency treegraph
 
Reported: 2012-12-26 07:20 EST by Kiril Nesenko
Modified: 2016-02-10 14:42 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (91.94 KB, text/x-log)
2012-12-26 07:20 EST, Kiril Nesenko
no flags Details
update_log (33.62 KB, text/x-log)
2013-01-06 03:43 EST, Kiril Nesenko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10690 None None None Never

  None (edit)
Description Kiril Nesenko 2012-12-26 07:20:28 EST
Created attachment 669203 [details]
log

Description of problem:
Upgrade fail on DB upgrade :


2012-12-26 12:19:34::DEBUG::rhevm-upgrade::426::root:: DB Update started
2012-12-26 12:19:34::DEBUG::common_utils::424::root:: Executing command --> '/usr/share/ovirt-engine/dbscripts/upgrade.sh -s localhost -p 5432 -u engine -d engine_2012_12
_26_12_18_59'
2012-12-26 12:19:35::DEBUG::common_utils::462::root:: output = upgrade script detected a change in Config, View or Stored Procedure...

2012-12-26 12:19:35::DEBUG::common_utils::463::root:: stderr = psql:create_functions.sql:679: ERROR:  must be owner of function uuid_generate_v1

2012-12-26 12:19:35::DEBUG::common_utils::464::root:: retcode = 3
2012-12-26 12:19:35::ERROR::rhevm-upgrade::1073::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-upgrade", line 1060, in main
    runFunc([db.update], MSG_INFO_DB_UPDATE)
  File "/usr/bin/rhevm-upgrade", line 608, in runFunc
    func()
  File "/usr/bin/rhevm-upgrade", line 443, in update
    output, rc = utils.execCmd(cmdList=cmd, failOnError=True, msg=MSG_ERROR_UPDATE_DB)
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 467, in execCmd
    raise Exception(msg)
Exception: Error: Database update failed

2012-12-26 12:19:35::ERROR::rhevm-upgrade::1074::r

Version-Release number of selected component (if applicable):
Upgrade from si25.2 to sf2

How reproducible:


Steps to Reproduce:
1. Upgrade from si25.1 to sf2
2.
3.
  
Actual results:
Upgrade fails

Expected results:


Additional info:
Comment 2 Kiril Nesenko 2013-01-06 03:43:52 EST
Created attachment 673301 [details]
update_log
Comment 4 Eli Mesika 2013-01-06 13:52:59 EST
http://gerrit.ovirt.org/#/c/10690/
Comment 5 Eli Mesika 2013-01-07 13:28:47 EST
fixed in commit : 51b5cbf
Comment 6 Ohad Basan 2013-01-23 12:06:17 EST
I experience the same failure on sf4
Comment 7 Eli Mesika 2013-01-23 17:23:33 EST
please attach logs
Comment 8 Ohad Basan 2013-01-24 05:04:53 EST
will open a different bug instead.
seems to be a different issue.
Comment 13 Itamar Heim 2013-06-11 05:00:20 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:00:21 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:00:24 EDT
3.2 has been released
Comment 16 Itamar Heim 2013-06-11 05:01:41 EDT
3.2 has been released
Comment 17 Itamar Heim 2013-06-11 05:31:06 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.