This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 890340 - RHEVM-CLI: logging into the cli not connected and running connect --help will log the user out of the cli
RHEVM-CLI: logging into the cli not connected and running connect --help will...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: 3.2.0
Assigned To: Ravi Nori
Ilia Meerovich
infra
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-26 09:30 EST by Dafna Ron
Modified: 2016-02-10 14:32 EST (History)
8 users (show)

See Also:
Fixed In Version: sf14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 13494 None None None Never
oVirt gerrit 13708 None None None Never

  None (edit)
Description Dafna Ron 2012-12-26 09:30:09 EST
Description of problem:

if we run rhevm-shell -> run connect --help -> we will be logged out of the cli 

Version-Release number of selected component (if applicable):

si25.2

How reproducible:

100%

Steps to Reproduce:
1. run rhevm-shell
2. connect --help 
3.
  
Actual results:

user will be logged out of the cli

Expected results:

we should not be logged out

Additional info:

[RHEVM shell (disconnected)]# connect --help
Usage: rhevm-shell [options]
       rhevm-shell [options] command...

This program is a command-line interface to RHEVM Virtualization.

Options:
  -h, --help            show this help message and exit
  -d, --debug           enable debugging
  -l URL, --url=URL     specifies the API entry point URL
                        (http[s]://server[:port]/api)
  -u USERNAME, --username=USERNAME
                        connect as this user
  -K KEY_FILE, --key-file=KEY_FILE
                        specify client PEM key-file
  -C CERT_FILE, --cert-file=CERT_FILE
                        specify client PEM cert-file
  -A CA_FILE, --ca-file=CA_FILE
                        specify server CA cert-file
  -I, --insecure        allow connecting to SSL sites without certificates
  -F, --filter          enables user permission based filtering
  -P PORT, --port=PORT  specify port
  -T TIMEOUT, --timeout=TIMEOUT
                        specify timeout
  -c, --connect         automatically connect
  -f FILE, --file=FILE  read commands from FILE instead of stdin
[root@rhevm-3 ~]#
Comment 1 Michael Pasternak 2012-12-26 09:48:19 EST
bug indeed, thanks Dafna,

just FYI, you using cli-like options in shell, please see 'help' to understand
how to work with shell.
Comment 2 Michael Pasternak 2013-01-06 09:12:04 EST
lowering priory since you've used incorrect argument for 'connect' command,
command's help syntax is 

help COMMAND <OBJECT> <OPTIONS>, see shell help/guide for more details
Comment 3 Ilia Meerovich 2013-05-13 05:46:19 EDT
sf15:

[RHEVM shell (connected)]# connect --help

USAGE
  
  connect
  connect <url> <username> <password> [command options]
  
DESCRIPTION
  
  Connect to a oVirt manager. This command has two forms. In the first
  form, no arguments are provided, and the connection details are read
  from their respective configuration variables (see 'show'). In
  the second form, the connection details are provided as arguments.
  
  The arguments are:
  
   * url               - The URL to connect to (http[s]://server[:port]/api).
   * username          - The user to connect as. (user@domain).
   * password          - The password to use.
   * [key-file]        - The client PEM key file to use.
   * [cert-file]       - The client PEM certificate file to use.
   * [ca-file]         - The server CA certificate file to use.
   * [filter]          - Enables user permission based filtering.
   * [insecure]        - Allow connecting to SSL sites without certificates.
   * [port]            - The port to use (if not specified in url).
   * [timeout]         - The request timeout.
   * [session-timeout] - The authentication session timeout (0 disables session expiry).
  
[RHEVM shell (connected)]#
Comment 4 Itamar Heim 2013-06-11 05:41:08 EDT
3.2 has been released
Comment 5 Itamar Heim 2013-06-11 05:41:16 EDT
3.2 has been released
Comment 6 Itamar Heim 2013-06-11 05:54:04 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.