Bug 890344 - spacewalk-service enable|disable relies on service scripts with potentially flawed dependancies.
spacewalk-service enable|disable relies on service scripts with potentially f...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2012-12-26 09:54 EST by William Brown
Modified: 2013-03-06 13:34 EST (History)
0 users

See Also:
Fixed In Version: spacewalk-java-1.9.36-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:34:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cobbler patch (492 bytes, patch)
2013-01-02 15:23 EST, Stephen Herr
no flags Details | Diff

  None (edit)
Description William Brown 2012-12-26 09:54:07 EST
/var/log/messages contains:


Dec 27 01:17:28 spacewalk systemd[1]: Reloading.
Dec 27 01:17:28 spacewalk systemd[1]: [/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on network,.service, ignoring: Invalid argument
Dec 27 01:17:28 spacewalk systemd[1]: [/etc/rc.d/init.d/cobblerd:10] Failed to add dependency on xinetd,.service, ignoring: Invalid argument
Dec 27 01:17:28 spacewalk systemd[1]: [/etc/rc.d/init.d/taskomatic:11] Failed to translate LSB dependency $local_fs,, ignoring: Invalid argument
Dec 27 01:17:28 spacewalk systemd[1]: [/etc/rc.d/init.d/taskomatic:11] Failed to add dependency on cobbler,.service, ignoring: Invalid argument


This may create an issue where dependancies for enabling or disabling of spacewalk are not resolved correctly. 

System is f17, x86_64.
Comment 1 Stephen Herr 2013-01-02 14:16:08 EST
The problem appears to be that we have a comma-separated list of services we depend on in those two files. The list should be space-separated, not comma-separated. fedoraproject.org/wiki/Packaging:SysVInitScript
Comment 2 Stephen Herr 2013-01-02 15:23:43 EST
Created attachment 671664 [details]
Cobbler patch

Committed taskomatic fix to Spacewalk master: 5519cb7ee8ddee38ccd740d7e6513553f3a0af96

**Note** when we port this fix over to an OS where we maintain the version of cobbler we use (e.g. RHEL) make sure to apply the attached patch to cobbler!
Comment 3 Stephen Herr 2013-01-02 15:26:20 EST
We (the Spacewalk devs) don't maintain cobbler in Fedora, so I can't fix the first couple of warnings here.
Comment 4 Stephen Herr 2013-03-01 12:07:21 EST
Marking bug as ON_QA since tonight's build of Spacewalk nightly is a release candidate for Spacewalk 1.9.
Comment 5 Stephen Herr 2013-03-06 13:34:46 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.