Bug 890349 - ovirt-engine-cli: error message for "help add [sub collections]" is not clear [TEXT]
Summary: ovirt-engine-cli: error message for "help add [sub collections]" is not clear...
Keywords:
Status: CLOSED DUPLICATE of bug 890328
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Michael Pasternak
QA Contact: Elena
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-26 15:16 UTC by Oded Ramraz
Modified: 2016-02-10 19:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-30 07:29:20 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description Oded Ramraz 2012-12-26 15:16:55 UTC
Description of problem:

error message for "help add sub collections" is not clear enough: "not enough arguments for format string"
This is true for sub collections such as quota, cdrom, permission, glustervolume, permit ...

See https://bugzilla.redhat.com/show_bug.cgi?id=890328 for more details. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# add 
brick          cluster        disk           group          network        permission     quota          snapshot       tag            user           vmpool         
cdrom          datacenter     glustervolume  host           nic            permit         role           storagedomain  template       vm             

## sub collections 

[RHEVM shell (connected)]# help add quota 

unknown error: not enough arguments for format string

[RHEVM shell (connected)]# help add cdrom

unknown error: not enough arguments for format string

## basic objects 

[RHEVM shell (connected)]# help add vm

USAGE
  
  add <type> [base identifiers] [attribute options]
  
DESCRIPTION

Comment 1 Barak Dagan 2012-12-26 17:56:53 UTC
Another help issue: getting directed to wrong "help page"

[RHEVM shell (connected)]# update host --name foo
error: wrong number of arguments, try 'help update' for help.

[RHEVM shell (connected)]# help update
unknown error: list index out of range

Comment 2 Michael Pasternak 2012-12-30 07:29:20 UTC

*** This bug has been marked as a duplicate of bug 890328 ***


Note You need to log in before you can comment on or make changes to this bug.