Bug 890447 - [elfutils] unit test failure in run-elflint-self.sh
Summary: [elfutils] unit test failure in run-elflint-self.sh
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: elfutils   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-27 01:18 UTC by Nick Black
Modified: 2013-08-15 02:37 UTC (History)
6 users (show)

Fixed In Version: elfutils-0.156-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-27 18:02:03 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nick Black 2012-12-27 01:18:15 UTC
I'm attempting to build and install elfutils-0.155 on SprezzOS Linux (the unit tests instruct one to report the bug here; sorry if this bug oughtn't be filed against Fedora). The unit tests fail there at run-elflint-self.sh:


PASS: run-elflint-test.sh
section [ 6] '.dynsym': symbol 63: st_value out of bounds
section [36] '.symtab': symbol 125: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/addr2line
section [37] '.symtab': symbol 169: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/elfcmp
section [37] '.symtab': symbol 270: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/elflint
section [ 6] '.dynsym': symbol 192: st_value out of bounds
section [37] '.symtab': symbol 305: st_value out of bounds
section [37] '.symtab': symbol 468: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/ld
section [ 6] '.dynsym': symbol 102: st_value out of bounds
section [37] '.symtab': symbol 234: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/nm
section [37] '.symtab': symbol 204: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/objdump
section [ 6] '.dynsym': symbol 148: st_value out of bounds
section [37] '.symtab': symbol 387: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/readelf
section [36] '.symtab': symbol 111: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/size
section [37] '.symtab': symbol 220: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/strip
section [37] '.symtab': symbol 311: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../libelf/libelf.so
section [37] '.symtab': symbol 619: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../libdw/libdw.so
FAIL: run-elflint-self.sh

This exception is wholly deterministic. I've only verified it on amd64 machines.

Steps to Reproduce:
1. Unpack elfutils-0.155.tar.gz
2. Run ./configure (succeeds)
3. Run make check (fails)

If 0.155 builds and runs successfully on Fedora boxes, feel free to tell me that, and with my apologies I'll determine what diverges on this setup. Thanks!

BTW, SprezzOS Bugzilla isn't in your "External Bugs" widget, but the link to SprezzOS bug 554 is: https://www.sprezzatech.com/bugs/show_bug.cgi?id=554

Comment 1 Mark Wielaard 2012-12-27 13:00:03 UTC
That is a known issue with GNU binutils PR ld/13621:
"dangling global hidden symbol in symtab"
http://sourceware.org/bugzilla/show_bug.cgi?id=13621

At one point it was fixed, but the fix was reverted again at a later point. so depending on which version of GNU ld you are using elflint will notice the issue (the binutils gold linker doesn't have this problem).

In Fedora we "cheat" and ignore this particular failure:
http://pkgs.fedoraproject.org/cgit/elfutils.git/tree/elfutils-0.155-binutils-pr-ld-13621.patch

Comment 2 Nick Black 2012-12-27 18:02:03 UTC
Thanks a lot for that detailed response, Mark! I'll look into the chain of events there. Perhaps another strategy could be employed.

I confirm the DUP-13621, and consider this bug resolved, though it seems prone to reduplication.

*** This bug has been marked as a duplicate of bug 13621 ***

Comment 3 Samuel Bronson 2013-02-13 22:41:38 UTC
Um, PR ld/13621 isn't on this bugtracker so I don't think there's a way to mark this as a duplicate of that ...

Comment 4 Mark Wielaard 2013-02-14 08:06:08 UTC
(In reply to comment #3)
> Um, PR ld/13621 isn't on this bugtracker so I don't think there's a way to
> mark this as a duplicate of that ...

yeah. In the end we came up with a different workaround upstream. It isn't very beautiful, but seems to do the trick for now:
https://lists.fedorahosted.org/pipermail/elfutils-devel/2013-February/002954.html

Comment 5 Fedora Update System 2013-08-08 11:16:34 UTC
elfutils-0.156-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/elfutils-0.156-3.fc19

Comment 6 Fedora Update System 2013-08-15 02:37:40 UTC
elfutils-0.156-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.