Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 890497 - Windows XP shutdown / restart causes Blue Screen
Summary: Windows XP shutdown / restart causes Blue Screen
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.3
Hardware: i386
OS: Windows
unspecified
unspecified
Target Milestone: rc
: 6.6
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-27 10:19 UTC by Alex Leonhardt
Modified: 2013-08-01 15:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-01 15:26:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (10.47 KB, image/png)
2012-12-27 10:19 UTC, Alex Leonhardt
no flags Details
XP restart after guest tools installed (11.10 KB, image/png)
2012-12-27 13:49 UTC, Alex Leonhardt
no flags Details

Description Alex Leonhardt 2012-12-27 10:19:30 UTC
Created attachment 669562 [details]
Screenshot

Description of problem:

When shutting down / restarting a Windows XP VM, it causes an exception in Windows and ends up as the well known Blue Screen of Death. 

Version-Release number of selected component (if applicable):

4.10

vdsm.x86_64           4.10.0-0.44.14.el6
                                        @vdsm31-dre                             


How reproducible:

Everytime

Steps to Reproduce:
1. Start a Win XP VM
2. Restart / Shutdown the Win XP host again
3. 
  
Actual results:

Just after logging off, the host will stop at a Blue Screen with message:

STOP: c000021a {Fatal System Error}
The Windows Logon Process system process terminated unexpectedly with a status code of 0xc0000096 (0x00000000 0x00000000).
The system has been shut down.

Expected results:

Clean shutdown.

Additional info:

Screenshot attached.

Comment 1 Dan Kenigsberg 2012-12-27 10:28:50 UTC
Please specify libvirt, qemu, and kernel versions, and attach relevant segment of vdsm.log.

I did not understand whether this happens during shutdown or on the next time a vm is started.

Either way, maybe Gal could help.

Comment 2 Gal Hammer 2012-12-27 10:34:14 UTC
Can you please provide more information?

Do you have the guest tools installed on that VM (guest-agent and single-sign-on)?
Which version?

Thanks.

Comment 3 Alex Leonhardt 2012-12-27 10:42:09 UTC
libvirtd (libvirt) 0.9.10

qemu-img-rhev.x86_64  2:0.12.1.2-2.295.el6.8
qemu-kvm-rhev.x86_64  2:0.12.1.2-2.295.el6.8

Kernel: 2.6.32-279.19.1.el6.x86_64

##

this happens during shutdown/restart only - starting up the VM and its function seems to be perfectly fine, however, I'm not sure of the follow-up effect of this happening (e.g. fs corruption, etc.)

##

OS is Windows XP SP2 (SP3 required?) 

Also, no - I have not installed any guest tools. Where do I find them ? 

##

Ta
Alex

Comment 4 Alex Leonhardt 2012-12-27 11:26:48 UTC
Where can I download the guest tools CD for Windows XP / 7 ? 

Thanks
Alex

Comment 5 Alex Leonhardt 2012-12-27 13:48:37 UTC
Found the ISO / rpm and installed the Guest Tools,  however, restart / shutdown now ends up in a "black / blank screen" - see attached a new screenshot. 

Alex

Comment 6 Alex Leonhardt 2012-12-27 13:49:52 UTC
Created attachment 669600 [details]
XP restart after guest tools installed

Comment 7 Alex Leonhardt 2012-12-31 13:26:18 UTC
Also, I just tried shutting down a XP VM - after seeing the black screen, I tried to use the "shutdown" button from the oVirt Web Interface - it then ends up again in a blue screen.

Comment 8 pf 2013-05-13 12:27:58 UTC
In case this helps anybody.

I also had the same problem, with a Windows XP machine I migrated from VMWare ESXi.

The problem was that, I hadn't uninstalled the VMWare Tools (before migration), and after the migration, the uninstaller no longer worked (gave an error about not knowing the version...).

Each time I shutdown the machine I got the BSOD with the error, and the NEXT TIME I booted the machine, after logging on, I got a request to send an error report (because winlogon.exe terminated in error).

This error was relative to VMUpgradeAtShutdownWXP.dll (A VMWare Tools DLL)

To make things simpler, please see the link:
http://botsikas.blogspot.pt/2012/11/migrating-from-esxi-to-hyper-v.html

Even though it is migration from ESXi -> Hyper-V, the error is still the same.

Even though, after following the steps in the link and using the VMWare uninstall tool (WHICH IS PROBABLY THE BEST AWAY and MIGHT AVOID OTHER PROBLEMs), the problem still persisted. I finally did just simply delete the VMUpgradeAtShutdownWXP.dll from the %windir%\system32 and the BSOD stopped.

Hope this helps,
PF

Comment 9 Ronen Hod 2013-08-01 15:26:58 UTC
Due to comment 8, transferring this bug to V2V
Closing this bug. If still relevant, please reopen through our support.

Thank you for taking the time to enter a bug report with us. We appreciate the feedback and look to use reports such as this to guide our efforts at improving our products. That being said, this bug tracking system is not a mechanism for requesting support, and we are not able to  guarantee the timeliness or suitability of a resolution.
 
If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution. 
 
For information on how to contact the Red Hat production support team, please visit:
https://www.redhat.com/support/process/production/#howto


Note You need to log in before you can comment on or make changes to this bug.