Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 890519 - [RFE] Provide both soft and hard reboot options in Horizon
Summary: [RFE] Provide both soft and hard reboot options in Horizon
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: beta
: 3.0
Assignee: Julie Pichon
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-27 13:25 UTC by Ofer Blaut
Modified: 2015-02-15 22:02 UTC (History)
7 users (show)

Fixed In Version: python-django-horizon-2013.1.1-3.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-19 19:53:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1088859 0 None None None Never
OpenStack gerrit 22300 0 None None None Never

Description Ofer Blaut 2012-12-27 13:25:44 UTC
Description of problem:

There are few issues on reboot instance via Horizon 
1. Currently reboot instance is rebooting HARD by default  ( CLI reboot soft by default )
2. We need option to select hard reboot instead of default one 
3. When user reboot Instance via CLI , Horizon doesn't display the current status ( i have check with SOFT & HARD reboot via CLI)



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. reboot instance via horizon ( defualt reboot is hard , no option to select soft/hard ) ( bug in upstream as well )
2. reboot via CLI: nova reboot --hard <instance ID >  , horizon doesn't upadete the GUI , even upon refresh 

  
Actual results:


Expected results:


Additional info:

Comment 2 Julie Pichon 2013-01-08 14:02:15 UTC
For 1 and 2, the upstream decision is going toward providing both soft and hard reboot options in the UI, to avoid just changing the current expected behaviour (see #1088859 on launchpad).

I can't reproduce 3. If I start a soft reboot from the CLI then refresh the instances list, I see the "Reboot" status on the Horizon instance page (Status: Reboot, Task: Rebooting, as long as the nova status is REBOOT). Doing a (single) manual refresh is necessary as Horizon only polls for changing instance status when there is an action on-going.

Comment 3 Julie Pichon 2013-02-05 09:57:11 UTC
Could you provide information on how to reproduce 3? As described in Comment 2, I can see the correct REBOOT status after refreshing the page.

Comment 4 Ofer Blaut 2013-02-05 10:11:01 UTC
Hi Julie

Seems that reboot is updating horizon on latest build 

python-django-horizon-2012.2.1-3.el6ost.noarch

Ofer

Comment 5 Julie Pichon 2013-02-05 11:11:54 UTC
Thank you Ofer. I'm going to update the bug summary to make it clearer what is left to resolve.

Comment 6 IanNeilsen 2013-04-04 04:20:23 UTC
Guys I think the below issue is very similar and didnt open a new bug for it.

Issue:

OpenStack dashboard displays one of my instances as showing "Status - Hard Reboot" and "Task - Rebooting Hard" on the /dashboard/nova/instances/ page.
I think the issue above refers to rebooting the machine via the CLI ssh login.

Step to reproduce:
Build a new instance using an image RHEL6.3.x86-64, 
ssh -i /home/username/.ssh/dropbear-name.pem cloud-user@10.X.X.X
do not install nova client tools
then perform a "reboot now" from the cli.

Although the machine reboots fine and runs fine, the dashboard shows the task as Rebooting Hard. Browser refresh does not work clear the statue and task message.

Comment 7 Julie Pichon 2013-04-04 13:01:55 UTC
Hi Ian. The status Horizon displays should come directly from Nova.

Could you run nova show <instance_id> and see what the status looks like in the output?

Also I think it would be better to open a new bug for this, rather than handle multiple issues in the one report. Thank you!

Comment 8 Matthias Runge 2013-05-15 07:42:06 UTC
(In reply to comment #6)
> Guys I think the below issue is very similar and didnt open a new bug for it.

> OpenStack dashboard displays one of my instances as showing "Status - Hard
> Reboot" and "Task - Rebooting Hard" on the /dashboard/nova/instances/ page.
> I think the issue above refers to rebooting the machine via the CLI ssh
> login.

Ian, is it possible, you're still using Essex? The path /dashboard/nova/instances does not exist in Grizzly, and I believe, it doesn't even exist in Folsom.

Comment 9 Matthias Runge 2013-06-03 14:46:42 UTC
OK, back to the original request, the option to hard and soft-reboot was added to horizon in the grizzly release.

Comment 10 Alvaro Lopez Ortega 2013-06-03 14:52:14 UTC
So, that implemented sub-request 1 and 2. The 3rd is missing, but we couldn't reproduce it and its needinfo request was logger 2 months ago. Unless Ian gets back to us soon, I'd vote for closing the bug.

Comment 11 Ofer Blaut 2013-06-05 12:02:22 UTC
works 

python-django-horizon-2013.1.1-2.el6ost.noarch


tested both item 1 &2

Comment 12 Scott Lewis 2013-06-19 19:53:16 UTC
Released with snap2.


Note You need to log in before you can comment on or make changes to this bug.