Bug 890524 - [REST-API] : error when adding disk with missing parameters need to be fixed [TEXT]
Summary: [REST-API] : error when adding disk with missing parameters need to be fixed ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.2.0
Assignee: Ravi Nori
QA Contact: Ilia Meerovich
URL:
Whiteboard: infra
Depends On:
Blocks: 915537 917401
TreeView+ depends on / blocked
 
Reported: 2012-12-27 14:16 UTC by Oded Ramraz
Modified: 2016-02-10 19:18 UTC (History)
8 users (show)

Fixed In Version: sf9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 10820 0 None MERGED restapi : error when adding disk with missing parameters(#890524) 2020-02-18 08:58:26 UTC
oVirt gerrit 12039 0 None MERGED restapi : error when adding disk with missing parameters(#890524) 2020-02-18 08:58:26 UTC

Description Oded Ramraz 2012-12-27 14:16:40 UTC
Description of problem:

When trying to add disk with missing parameters I get error with superfluous 0:
 Disk [format, interface] required for invoke0
I saw this invoke error in other places as well .

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# add disk --name oded

error:
status: 400
reason: Bad Request
detail: Disk [format, interface] required for invoke0

Comment 1 Ravi Nori 2013-01-09 15:04:45 UTC
Link : http://gerrit.ovirt.org/#/c/10820/

change id : Idc57a93fee99859ba26bcc0bd5b25035358f5734

Comment 2 Ilia Meerovich 2013-02-10 19:56:57 UTC
still function name appears in error message:

[imeerovi@imeerovi ART]$ /usr/bin/rhevm-shell -c --url=https://leonid_rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal -I 

 ==========================================
 >>> connected to RHEVM manager 3.1.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# add disk --name this_is_bug

error: 
status: 400
reason: Bad Request
detail: Disk [format, interface] required for validateDiskForCreation

[RHEVM shell (connected)]# exit
[imeerovi@imeerovi ART]$ rpm -q rhevm-cli
rhevm-cli-3.2.0.3-1.el6ev.noarch
[imeerovi@imeerovi ART]$

Comment 3 Ravi Nori 2013-02-11 17:47:13 UTC
It works for me with 3.2. Why does it say >>> connected to RHEVM manager 3.1.0.0 <<< in your message?

(In reply to comment #2)
> still function name appears in error message:
> 
> [imeerovi@imeerovi ART]$ /usr/bin/rhevm-shell -c
> --url=https://leonid_rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal
> -I 
> 
>  ==========================================
>  >>> connected to RHEVM manager 3.1.0.0 <<<
>  ==========================================
> 
> 
>         
>  ++++++++++++++++++++++++++++++++++++++++++
>  
>            Welcome to RHEVM shell
>  
>  ++++++++++++++++++++++++++++++++++++++++++
>         
>     
> [RHEVM shell (connected)]# add disk --name this_is_bug
> 
> error: 
> status: 400
> reason: Bad Request
> detail: Disk [format, interface] required for validateDiskForCreation
> 
> [RHEVM shell (connected)]# exit
> [imeerovi@imeerovi ART]$ rpm -q rhevm-cli
> rhevm-cli-3.2.0.3-1.el6ev.noarch
> [imeerovi@imeerovi ART]$

Comment 4 Michael Pasternak 2013-02-13 08:27:34 UTC
(In reply to comment #2)
> still function name appears in error message:
> 
> [imeerovi@imeerovi ART]$ /usr/bin/rhevm-shell -c
> --url=https://leonid_rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal
> -I 
> 
>  ==========================================
>  >>> connected to RHEVM manager 3.1.0.0 <<<
>  ==========================================
> 
> 

Ilia,

this is 3.2 bug, but from your cli prompt, looks like you verifying it against 3.1, please recheck on 3.2 build >= sf4

Comment 5 Ilia Meerovich 2013-02-13 14:21:55 UTC
 >>> connected to RHEVM manager 3.2.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# add disk --name this_is_bug --format bug --interface bug

error: 
status: 400
reason: Bad Request
detail: Disk [provisionedSize|size] required for invoke

[RHEVM shell (connected)]#

Comment 6 Ilia Meerovich 2013-05-13 09:23:11 UTC
with sf15:

 ==========================================
 >>> connected to RHEVM manager 3.2.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]# add disk --name this_is_bug --format bug --interface bug

error: 
status: 400
reason: Bad Request
detail: Disk [provisionedSize|size] required for add

[RHEVM shell (connected)]# 
[imeerovi@imeerovi ART]$ rpm -q rhevm-cli
rhevm-cli-3.2.0.9-1.el6ev.noarch

Comment 7 Itamar Heim 2013-06-11 09:03:29 UTC
3.2 has been released

Comment 8 Itamar Heim 2013-06-11 09:03:37 UTC
3.2 has been released

Comment 9 Itamar Heim 2013-06-11 09:03:45 UTC
3.2 has been released

Comment 10 Itamar Heim 2013-06-11 09:04:15 UTC
3.2 has been released

Comment 11 Itamar Heim 2013-06-11 09:33:20 UTC
3.2 has been released


Note You need to log in before you can comment on or make changes to this bug.