Bug 89055 - Build of SRPM fails for Samba
Summary: Build of SRPM fails for Samba
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-16 22:59 UTC by Ian Prowell
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 21:06:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Prowell 2003-04-16 22:59:48 UTC
Description of problem:


Version-Release number of selected component (if applicable):
2.2.7-5.8.0

How reproducible: Always


Steps to Reproduce:
1. Install SRPM: rpm -Uvh samba-2.2.7-5.8.0.src.rpm
2. Try to build: rpmbuild -ba /usr/src/redhat/SPEC/samba.spec
3. Build fails with error: checking for test routines... configure: error: cant
find test code. Aborting config
    
Actual results:
Build fails

Expected results:
Build should work

Additional info:
This seems to be caused by openssl-devel not being installed.  This should be
added to the BuildRequires line in the .spec file.

Comment 1 Jay Fenlason 2003-04-21 18:03:59 UTC
WORKSFORME.  You'll need to provide more details if you want me to have any
chance of debugging this.  I do not have openssl-devel installed on my test box,
so that's probably not te problem.

Please attach the output of "rpm -q -a" and a script of an attempted build to
this bug report.

Comment 2 Ian Prowell 2003-04-30 17:40:17 UTC
You can go ahead and close this.  I have not been able to reproduce the issue
once I added openssl-devel.


Note You need to log in before you can comment on or make changes to this bug.