Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 890594 - [virtio-win[scsi]Shutdown guest will lead to BSOD during disabling driver
[virtio-win[scsi]Shutdown guest will lead to BSOD during disabling driver
Status: CLOSED DUPLICATE of bug 846912
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
:
Depends On:
Blocks: 896495
  Show dependency treegraph
 
Reported: 2012-12-27 21:16 EST by Min Deng
Modified: 2013-07-01 00:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 08:50:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2012-12-27 21:16:28 EST
Description of problem:
  After guest does S3 and disables driver from device manager,and then shutdown the guest.Finally,the guest got BSOD(9f) issue.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-49
How reproducible:
4 times 4 failed

Steps to Reproduce:
1./usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic,family=0xf -usb -device usb-tablet -device virtio-scsi-pci,id=scsi0 -drive file=win7-32-clean.raw,format=raw,if=none,id=drive-virtio0,cache=writethrough,werror=stop,rerror=stop -device ide-drive,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=2 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:52:26:27:51:c6 -uuid e556eb83-f793-48e2-9661-b0f17499834d -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win7-64-scsi,server,nowait -mon chardev=111a,mode=readline -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -device virtio-scsi-pci,id=scsi4 -drive file=disk4.raw,if=none,format=raw,cache=none,id=drive-virtio-data4,werror=stop,rerror=stop -device scsi-hd,bus=scsi4.0,id=virtio-data4,drive=drive-virtio-data4,serial=dsik44,lun=4 -drive file=/mnt/add30.qcow2,if=none,format=qcow2,cache=none,id=drive-virtio-data5,werror=stop,rerror=stop -device scsi-hd,bus=scsi4.0,id=virtio-data5,drive=drive-virtio-data5,serial=dsik44,lun=5 -M rhel6.4.0 -monitor stdio -qmp tcp:0:4444,server,nowait -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -spice port=5931,disable-ticketing -vga qxl -rtc base=localtime,clock=host,driftfix=slew
2.do s3 and resume guest
3.go to device manager and disable the driver
4.and then shutdown the guest  
Actual results:
The guest got BSOD issues
Expected results:
The guest works well even if the driver is disabling.
Additional info:
Comment 1 Min Deng 2012-12-27 21:17:36 EST
Dump analysis
!analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_POWER_STATE_FAILURE (9f)
A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arguments:
Arg1: 00000003, A device object has been blocking an Irp for too long a time
Arg2: 845f2030, Physical Device Object of the stack
Arg3: 8272aae0, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
Arg4: 849d9508, The blocked IRP

Debugging Details:
------------------


DRVPOWERSTATE_SUBCODE:  3

IMAGE_NAME:  vioscsi.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  50b73b32

MODULE_NAME: vioscsi

FAULTING_MODULE: 95d3b000 vioscsi

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

BUGCHECK_STR:  0x9F

PROCESS_NAME:  System

CURRENT_IRQL:  2

STACK_TEXT:  
8272aa94 826c9637 0000009f 00000003 845f2030 nt!KeBugCheckEx+0x1e
8272ab00 826c96b0 8272aba0 00000000 82737380 nt!PopCheckIrpWatchdog+0x1f5
8272ab38 8267b799 827456e0 00000000 77997f76 nt!PopCheckForIdleness+0x73
8272ab7c 8267b73d 8272dd20 8272aca8 00000001 nt!KiProcessTimerDpcTable+0x50
8272ac68 8267b5fa 8272dd20 8272aca8 00000000 nt!KiProcessExpiredTimerList+0x101
8272acdc 8267978e 00015301 85b63020 82737380 nt!KiTimerExpiration+0x25c
8272ad20 826795b8 00000000 0000000e 00000000 nt!KiRetireDpcList+0xcb
8272ad24 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x38


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  0x9F_3_disk_IMAGE_vioscsi.sys

BUCKET_ID:  0x9F_3_disk_IMAGE_vioscsi.sys

Followup: MachineOwner
---------
Comment 3 Min Deng 2012-12-27 21:34:45 EST
Dumps is here \\smamit.eng.lab.tlv.redhat.com\win-team\Public\QE\890594
Comment 5 dawu 2012-12-28 00:43:11 EST
This BSOD looks more probably caused by bug  https://bugzilla.redhat.com/show_bug.cgi?id=846912, since disable or enable scsi driver will stuck after S3/S4,if you reboot or shutdown guest at this time, this device will be blocking an Irp for too long a time and finally BSOD with 9f code.

I have tried this on win2k8-64, driver disable stuck after S3,and I reboot guest,BSOD happened.

If something wrong, please correct me, thanks!

Best Regards,
Dawn
Comment 6 RHEL Product and Program Management 2012-12-31 01:47:43 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 7 Gal Hammer 2013-02-18 08:50:51 EST
I agree with Dawn (comment #5), closing as duplicate.

*** This bug has been marked as a duplicate of bug 846912 ***

Note You need to log in before you can comment on or make changes to this bug.