Bug 890622 - (hdmithaw) hdmi audio fails after hibernate-thaw
hdmi audio fails after hibernate-thaw
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-12-28 03:27 EST by Arne Woerner
Modified: 2013-01-29 03:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 03:20:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
audio related syslog messages (1.19 KB, text/plain)
2012-12-28 03:27 EST, Arne Woerner
no flags Details

  None (edit)
Description Arne Woerner 2012-12-28 03:27:54 EST
Created attachment 669789 [details]
audio related syslog messages

Description of problem:
When I do some (e. g. 2) hibernate-thaw-cycles I cannot use HDMI audio anymore.
It doesnt happen each time, but i have to reboot if i want to fix it...
I use
os: Fedora Core 17 (fully updated)
sound system: pulseaudio
cpu: AMD A10-5800K
mainboard: GigaByte GA-F2A75M-D3H

Version-Release number of selected component (if applicable):
Linux vaako.intern.wgboome.org 3.6.10-2.fc17.x86_64 #1 SMP Tue Dec 11 18:07:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
sometimes 3 thaw-s r successful...

Steps to Reproduce:
1. start mplayer and pause
2. hibernate-thaw
3. continue mplayer
  
Actual results:
Sometimes there is no sound with the following symptoms:
Pulseaudio's volume meter either shows zero volume or the volume bar doesnt
flicker as rapid as it should and video playback is slow and jumpy.
When I switch the mplayer process to the analog audio sink, audio+video work fine again.
Restarting pulseaudio+mplayer doesnt help.
Reloading the kernel module (fglrx) doesnt help.
Rmmod-ing the snd_hda_intel module crashes the box.

Expected results:
audio should work after thaw like it did before hibernate...

Additional info:
i added audio related syslog lines
i filed a bug report here: http://ati.cchtml.com/show_bug.cgi?id=681
Comment 1 Arne Woerner 2012-12-29 03:48:14 EST
i found a workaround:
1. i do this before hibernate:
   > ( echo set-card-profile alsa_card.pci-0000_00_01.1 off ; \
       echo set-card-profile alsa_card.pci-0000_00_14.2 off ) | pacmd
2. and set the proper profiles after thaw
3. when the HDMI profile fails, then i let it hibernate-thaw again
   (with profiles set to 'off'),
   but in fake mode
   (in order to avoid a power cycle):
   # echo reboot > /sys/power/disk

does it help to debug that problem?
why is it, that the HDMI audio sometimes thaws properly and sometimes it doesnt?
Comment 2 Arne Woerner 2013-01-29 03:20:16 EST
it seems like it is fixed now (since a week or so)... :-)

Note You need to log in before you can comment on or make changes to this bug.