Bug 89067 - Network install can't find NIC
Network install can't find NIC
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 00:31 EDT by Alex Turner
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 16:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Turner 2003-04-17 00:31:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1)
Gecko/20021104 Chimera/0.6

Description of problem:
When doing an install from FTP, the installer cannot seem to find the network
card at all.  The network card is an SMC RTL8139 based card.  This has occurred
on two different machines so far, one is a P90 compaq Presario CDS972 (which is
a DNS server) and the other is a Pentium II 300.  I am upgrading our datacenter
tonight, and I will add comments about other systems as they become available.
I put in the device driver disk, and it just wont find the network card, even
when I pick it from the list.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run installer from Floppy Disk
2.type 'linux text'
3.select FTP Install type
    

Actual Results:  The system asks me for the device driver disk, and then tells
me it cannot find any suitable device, would I like to pick one.  I try to pick
one, and it then gives me the list.  I select the relavent card, and it just fails.

Expected Results:  Installed should have picked up the network card without user
interaction, or at least be able to insert module.

Additional info:

I have installed RedHat 9 from the CD onto the first system (the P90) and it
picks up the card fine during the normal install process.  I can't install it
from CD on the PII because it doesn't have a CD drive currently.
Comment 1 Alex Turner 2003-04-17 23:40:29 EDT
the PII 300 is a ne2k-pci card.  I am going to try also on our Dell Power Edge 
systems.
Comment 2 Alex Turner 2003-04-17 23:54:41 EDT
This does however seem to work on our PowerEdge 350 PIII 850 with an eepro100 
just fine.  I guess it's the older crappy hardware, although it is probably 
worth noting that I have had other issues with the rtl8139 based network cards 
in the past, although not this particularl model.
Comment 3 Alex Turner 2003-04-18 00:35:52 EDT
Hmmm.. insteresting.

It failed to probe the eepro100 on the powereedge, but now I'm trying a 
different card in this PII 300, an SMC 50something: It probed it and took me 
straight to the IP config screen.
Comment 4 Bill Nottingham 2003-04-22 22:56:26 EDT
Post-install, do the cards work?
Comment 5 Alex Turner 2003-04-24 09:14:20 EDT
Yes They do.  All of them.
Comment 6 Bill Nottingham 2003-04-24 10:53:32 EDT
What errors do you get if you manually pick the driver?
Comment 7 Alex Turner 2003-04-24 12:20:05 EDT
It tells me that it cannot find a suitable device etc. In the case of the RTL
8139 based SMC card, but it work in the case of the eepro100.
Comment 8 Bill Nottingham 2003-04-24 12:40:54 EDT
Are there errors on vt3/vt4 when it tries to load the module?
Comment 9 Bill Nottingham 2005-09-23 16:03:47 EDT
Closing out bugs on older, no longer supported, releases. Apologies for any lack
of response.

Please test this bug on a current release, such as Fedora Core 4. If it persists
there, please file a new bug.

Note You need to log in before you can comment on or make changes to this bug.