Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 89076 - amavisd-new hangs in rt_sigsuspend([]
Summary: amavisd-new hangs in rt_sigsuspend([]
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-17 09:20 UTC by Frank Reppin
Modified: 2016-11-24 15:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-22 08:49:36 UTC


Attachments (Terms of Use)
straceoutput (378.09 KB, text/plain)
2003-04-17 09:23 UTC, Frank Reppin
no flags Details

Description Frank Reppin 2003-04-17 09:20:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Since the recommended update from glibc-2.2.93 to
those newer version amavisd-new won't start anymore.

strace shows me, that the startup doesn't succeed:

---snip---
time([1050570453])                      = 1050570453
getpid()                                = 31473
rt_sigprocmask(SIG_SETMASK, NULL, [RTMIN], 8) = 0
rt_sigsuspend([]
---snap---

Here it hangs forever. 

It magically works again as expected if I downgrade
glibc to 2.2.93 (stock RH8 CD versions).

Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80 && glibc-2.3.2-4.80.6 (&& glibc-2.3.2-27.9)

How reproducible:
Always

Steps to Reproduce:
1. update to 2.3.x glibc
2. try to start amavisd-new (http://www.ijs.si/software/amavisd/)
3. *notice that it won't start*
4. downgrade to glibc-2.2.x
5. everything's ok.    

Actual Results:  startup fails/hangs in uncommon state.

Expected Results:  should startup nicely :p

Additional info:

I use a perl-5.8.0 compiled from sources and a vanilla 2.4.20 kernel.
amavisd-new worked fine (as already mentioned above) until the
glibc update. I already recompiled perl-5.8.0/kernel after upgrading
to glibc-2.3.x ... but the problem still persists :/

Comment 1 Frank Reppin 2003-04-17 09:23:40 UTC
Created attachment 91172 [details]
straceoutput

Comment 2 Frank Reppin 2003-04-19 00:34:46 UTC
worksforme: after recompiling Perl with '-lpthread' (threading Perl)
the problem vanished. however, I have no idea where glibc-2.2.93 and
glibc-2.3.2 differ in detail there.
Maybe someone can shed some light on this whilst closing the bug. TIA.


Comment 3 Ulrich Drepper 2003-04-22 08:49:36 UTC
Isn't perl by default compiled with threads?  In this case the only thing which
changed is IIRC the binary compatibility change for the new sizes of condvars. 
Perl without recompilation would use the compatibility code which I would expect
has no problems.

Anyway, if a new perl fixes the problem this is certainly good enough for me. 
On an RHL9 system you would get all this for free, without recompilation.


Note You need to log in before you can comment on or make changes to this bug.