Bug 890805 - sendpage fails when submitting message.
Summary: sendpage fails when submitting message.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hylafax+
Version: 17
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lee Howard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-30 09:48 UTC by Frank Crawford
Modified: 2013-03-29 01:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 21:27:54 UTC


Attachments (Terms of Use)

Description Frank Crawford 2012-12-30 09:48:44 UTC
Description of problem:
When attempting to submit a pager/SMS message via SNPP, sendpage fails when attempting to submit job.

Version-Release number of selected component (if applicable):
hylafax+-5.5.2-6.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install hylafax+, setup modem, pagermap & info file.
2. Submit page as "sendpage -p frank -v Testing"
3. View both output and syslog results
  
Actual results:
Sendpage result is:
Trying localhost (127.0.0.1) at port 444...
Connected to localhost.
220 abc.def.au SNPP server (HylaFAX (tm) Version 5.5.2) ready.
-> LOGI XXXX
250 User root logged in.
-> SITE HELP NOTIFY
218 Syntax: SITE NOTIFY [NONE|DONE|REQUEUE|DONE+REQUEUE]
-> LEVE 1
250 OK, service level 1 accepted.
-> SITE FROMUSER root
250 FROMUSER set to "root".
-> SITE MAXDIALS 12
250 MAXDIALS set to 12.
-> SITE MAXTRIES 3
250 MAXTRIES set to 3.
-> SITE MAILADDR root@abc.def.au
250 NOTIFYADDR set to "root@abc.def.au".
-> SITE NOTIFY none
250 NOTIFY set to "none".
-> SITE JQUEUE no
250 Job will not be queued.
-> PAGE frank
250 Pager ID accepted; provider: XXXXXX pin: YYYYYYYYY jobid: 13.
destination pin frank: request id is 12 for host localhost
-> MESS Testing
250 Message text OK.
-> SEND
554 Failed to submit message 12: Unspecified reason (scheduler NAK'd request).
sendpage: 554 Failed to submit message 12: Unspecified reason (scheduler NAK'd request).

Syslog reports:
Dec 30 20:37:07 bits FaxQueuer[31362]: TRIGGER J0010
Dec 30 20:37:07 bits FaxQueuer[31362]: SUBMIT JOB 12
Dec 30 20:37:07 bits FaxQueuer[31362]: sendq/q12: line 79: Can not access document file "YYYYYYYY": No such file or directory
Dec 30 20:37:07 bits FaxQueuer[31362]: sendq/q12: line 79: Rejected document in corrupt job request
Dec 30 20:37:07 bits FaxQueuer[31362]: JOB 12 : Invalid or corrupted job description file {E326}
Dec 30 20:37:07 bits FaxQueuer[31362]: NOTIFY: bin/notify 'doneq/q12' 'rejected' ''
Dec 30 20:37:07 bits FaxQueuer[31362]: DELETE 0

Expected results:
Pager message should be delivered via IXO protocol.

Additional info:
The same configuration worked with hylafax-server 6.0.5 (and earlier version).

Comment 1 Lee Howard 2012-12-31 06:19:58 UTC
I've fixed that upstream with this small change:

http://hylafax.cvs.sourceforge.net/viewvc/hylafax/hylafax/faxd/FaxRequest.c%2B%2B?r1=1.24&r2=1.25

I'll push a new build in a few days.

Comment 2 Frank Crawford 2013-02-21 11:32:27 UTC
(In reply to comment #1)
> I've fixed that upstream with this small change:
> 
> http://hylafax.cvs.sourceforge.net/viewvc/hylafax/hylafax/faxd/FaxRequest.
> c%2B%2B?r1=1.24&r2=1.25
> 
> I'll push a new build in a few days.

Lee, what happened to the new build?

Comment 3 Lee Howard 2013-02-22 06:28:45 UTC
I'm sorry for the delay.  I'm trying to get several issues addressed concurrently so as to not have to push several new builds.  Right now upstream a release candidate for 5.5.3 is being tested in several production deployments, and presuming all goes well I would like to release that this weekend and I should then be able to push a new build here immediately afterwards.

Comment 4 Frank Crawford 2013-02-22 11:44:58 UTC
Lee, thanks.  FYI, the reason I was asking is that for F18 hylafax crashes, so now is the perfect time to move to hylafax+.

Comment 5 Fedora Update System 2013-02-26 07:03:28 UTC
hylafax+-5.5.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hylafax+-5.5.3-1.fc17

Comment 6 Fedora Update System 2013-02-26 07:16:43 UTC
hylafax+-5.5.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hylafax+-5.5.3-1.fc18

Comment 7 Fedora Update System 2013-02-26 07:38:02 UTC
hylafax+-5.5.3-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/hylafax+-5.5.3-1.el5

Comment 8 Fedora Update System 2013-02-26 07:50:27 UTC
hylafax+-5.5.3-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/hylafax+-5.5.3-1.el6

Comment 9 Fedora Update System 2013-02-26 19:16:43 UTC
Package hylafax+-5.5.3-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing hylafax+-5.5.3-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0453/hylafax+-5.5.3-1.el5
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2013-03-19 21:27:56 UTC
hylafax+-5.5.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-03-19 21:28:36 UTC
hylafax+-5.5.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-03-20 21:58:30 UTC
hylafax+-5.5.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-03-29 01:36:54 UTC
hylafax+-5.5.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.