Bug 89081 - Greek TrueType fonts for Mozilla are displayed incorrectly
Greek TrueType fonts for Mozilla are displayed incorrectly
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
http://www.df.lth.se/~triad/moztest.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 07:45 EDT by Linus Walleij
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 12:13:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Walleij 2003-04-17 07:45:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Look at the web page in the URL. The TrueType fonts used by Mozilla seem to be
missing a number of greek characters, notably Rho, and several accented
variants. This could also be caused by bad rendering of existing fonts of course...

Version-Release number of selected component (if applicable):
mozilla-1.2.1-26

How reproducible:
Always

Steps to Reproduce:
1. Open mozilla
2. Surf to the URL
3. See words with missing characters
    

Actual Results:  "Paranoia" and "Gnosis" are missing characters.

Expected Results:  The words should have rendered correctly.

Additional info:
Comment 1 Linus Walleij 2003-04-20 17:52:40 EDT
Looking closer at this, I see that this error may be due to the fact that I use
very odd greek unicode characters, such as omega with a tilde above it. This may
actually be a rendering bug, that occurs mostly because of mixing low-res and
TTF fonts. It still should not happen though.
Comment 2 Javier Gostling D. 2003-05-06 16:59:48 EDT
This issue is not restricted to greek. I have a Latinamerican keyboard and I'm
experiencing the same problem when I type accented vowels. I tried to setup
mozilla to use Unicode UTF-8 everywhere I found it in Preferences, but that
didn't help at all.

For reference, the contents of my /etc/sysconfig/i18n are

$ cat /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:es_CL.UTF-8:es_CL:es"
SYSFONT="latarcyrheb-sun16"
$

Comment 3 Javier Gostling D. 2003-05-06 18:20:23 EDT
I just tried removing the UTF-8 enconding from /etc/sysconfig/i18n and after
that (and restarting my X session) Mozilla would allow me to type accented
vowels normally. Unfortunately, there are some issues (mainly interoperating
with other systems which are setup for UTF-8) which forced me to reset
/etc/sysconfig/i18n to UTF-8.

A workaround this issue is to start Mozilla from the command line with a line
like the following:

$ LANG=en_US mozilla
       ^^^^^
Put your language here

This will also make Mozilla behave with regards to accents. From this
diagnostics, I think this is a Mozilla issue rather than a Redhat issue, but I
will leave that to the Redhat experts.
Comment 4 Linus Walleij 2003-05-07 01:02:36 EDT
If *typing* characters is your problem, that is probably unrelated to this issue
which is mostly about *displaying* certain characters.

(UTF-8 in i18n is the cause of several other problems as well, such as accessing
old filesystems based on ISO 8859-1 which is what is used for en_US, but that is
not the issue here.)
Comment 5 Christopher Blizzard 2003-06-02 10:35:00 EDT
It's hard to say.  The default encoding can affect how some web pages are
rendered because it's going to choose a different font based on what your
setting is.
Comment 6 Linus Walleij 2004-02-13 12:13:00 EST
This works for me in Fedora Core 2 test 1 w/Mozilla 1.6. Let's close it!

Note You need to log in before you can comment on or make changes to this bug.