Bug 89085 - xfree black screen when using ati radeon 7000 with dri
xfree black screen when using ati radeon 7000 with dri
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 09:27 EDT by randy smyth
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-20 22:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xfree log (35.35 KB, text/plain)
2003-04-17 09:30 EDT, randy smyth
no flags Details

  None (edit)
Description randy smyth 2003-04-17 09:28:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
when i try to start x with dri enabled for my ati readion 7000 pci i get a black
screnn ill include a log for more info.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. startx with ati readion 7000

    

Actual Results:  black screen

Expected Results:  3d acell working

Additional info:
Comment 1 randy smyth 2003-04-17 09:30:36 EDT
Created attachment 91173 [details]
xfree log

hear it is
Comment 2 Mike A. Harris 2003-04-19 04:19:02 EDT
The attached log file shows a properly working Xserver, and Radeon 7000
works fine for me on several machines here, so it isn't clear what the
problem is that you are experiencing without a lot more information,
and detailed steps on how to reproduce.  Can you please provide a detailed
explanation of the problem, and how to reproduce it.

Also try disabling DRI by commenting out the line in the config file which
loads the DRI module.
Comment 3 Mike A. Harris 2003-04-19 04:21:10 EDT
Correcting incorrect spelling in summary of "readion", changed to correct
spelling of "radeon" so it comes up properly in search queries.
Comment 4 randy smyth 2003-04-20 22:21:32 EDT
never mind ForcePCIMode worked fine.
Comment 5 Need Real Name 2003-04-27 04:01:45 EDT
Had the same problem described above. Thankfully I found this bug report as 
the 'Option "ForcePCIMode"' addition to XF86Config fixed the problem.

Perhaps this option should be added by default as the only way to successfully 
install with this card that I have found is to use linux expert at cd boot 
time then specify text mode login when configuring with anaconda then editing 
the XF86Config file and changing to gui login again - a real pain.

Thanks.
Comment 6 Mike A. Harris 2003-04-28 08:38:30 EDT
The ForcePCIMode option is an option to begin with because it enables
experimental code which is unsupported and known to create problems for
many people.  It is very hardware dependant, and it is defaulted to OFF
very purposefully.   It is however an option, so that people who need/want
to use it, can.

There is no way to detect when ForcePCIMode can be used safely, and when
it will cause problems, and there is no way to determine what cards might
need it and which ones do not.


Note You need to log in before you can comment on or make changes to this bug.