Bug 89086 - core dumps are broken
Summary: core dumps are broken
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-17 13:48 UTC by Joe Orton
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version: httpd-2.0.40-21.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-22 14:07:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2003-04-17 13:48:18 UTC
setuid apps won't dump core; need to call prctl(PR_SET_DUMPABLE,1) so that httpd
is dumpable.

Comment 1 Joe Orton 2003-07-09 10:11:31 UTC
It turns out that the Red Hat kernel patches include a change which prevents a
process ever turning the "dumpable" flag back on using the prctl call above, so
this won't work without kernel changes.

Comment 2 Joe Orton 2003-07-22 14:07:56 UTC
There's nothing more that httpd can do - the only problem is bug 98825.


Note You need to log in before you can comment on or make changes to this bug.