Bug 89087 - Default displaymanager incorrect configured
Summary: Default displaymanager incorrect configured
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-17 14:15 UTC by Dennixx
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 19:13:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dennixx 2003-04-17 14:15:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I installed a system using kickstart. In the configuration file I have the
following line:

xconfig --depth=24 --resolution=1024x768 --defaultdesktop=KDE --startxonboot

the problem is with the defaultdesktop directive. It doesn't work!
I traced it to be the following problem:

in previous versions, the configuration file /etc/sysconfig/desktop should contain 
DESKTOP="KDE"

In version 9. it should contain
DISPLAYMANAGER="KDE"
but it still contains the 'DESKTOP' line, which isn't interpreted by /etc/X11/prefdm

I'm not sure if this is a bug in kickstart, or in anaconda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Linux 9 using kickstart (or perhaps even manually)
2. 
3.
    

Actual Results:  cat /etc/sysconfig/desktop
DESKTOP="KDE"

Expected Results:  cat /etc/sysconfig/desktop
DISPLAYMANAGER="KDE"

Additional info:

Comment 1 Stig Nielsen 2003-04-21 04:51:56 UTC
I installed 2 machines, 1 personal and one custom with all packages, manually -
out of the box and experienced the same thing on both machines.

Comment 2 Michael Fulbright 2003-05-13 18:37:45 UTC
Doesn't the default gdm login screen come up ok, with KDE as the default desktop
once you install?

GDM is the login manager we configure, independent of the default desktop.

Comment 3 Dennixx 2003-05-14 07:53:47 UTC
In previous versions the choice for displaymanager was done from the default
desktop. In /etc/X11/prefdm on 7.3 you'll find the line

[ -n "$DISPLAYMANAGER" ] && DESKTOP=$DISPLAYMANAGER

That's why my approach worked in earlier versions.
Apparently this has been abandoned in newer versions.


Comment 4 Michael Fulbright 2003-05-20 18:53:08 UTC
We always default to gdm if it exists.

Will forward this bug to gdm so that its maintainer can explain the reasoning
and how to override.

Comment 5 Havoc Pennington 2003-05-20 19:13:42 UTC
The default desktop setting changes your desktop; the default display manager
setting changes your display manager. The settings are separate, so you 
can set them separately. For example, a default install sets them 
separately. But if you want to set the two settings to "match" you can of course
do that.

Do you want changing your default web browser to magically change your 
default email client? It doesn't make sense to have two apps just 
randomly bound together.



Note You need to log in before you can comment on or make changes to this bug.