Bug 890879 - [abrt] gdb-7.5.0.20120926-25.fc18: lookup_minimal_symbol_text: Process /usr/bin/gdb was killed by signal 11 (SIGSEGV)
Summary: [abrt] gdb-7.5.0.20120926-25.fc18: lookup_minimal_symbol_text: Process /usr/b...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3a3e77e3134896af029c7ca4a67...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-30 22:46 UTC by Jan Teichmann
Modified: 2013-01-10 08:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-10 08:54:50 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (13.10 KB, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: cgroup (156 bytes, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: core_backtrace (1.41 KB, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: dso_list (3.11 KB, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: environ (327 bytes, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: limits (1.29 KB, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: maps (15.92 KB, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: open_fds (372 bytes, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: proc_pid_status (882 bytes, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details
File: var_log_messages (292 bytes, text/plain)
2012-12-30 22:46 UTC, Jan Teichmann
no flags Details

Description Jan Teichmann 2012-12-30 22:46:06 UTC
Version-Release number of selected component:
gdb-7.5.0.20120926-25.fc18

Additional info:
backtrace_rating: 4
cmdline:        gdb -batch -ex 'set debug-file-directory /' -ex 'file /usr/bin/wxmaxima' -ex 'core-file ./coredump' -ex 'thread apply all backtrace 2048 full' -ex 'info sharedlib' -ex 'print (char*)__abort_msg' -ex 'print (char*)__glib_assert_msg' -ex 'info registers' -ex disassemble
crash_function: lookup_minimal_symbol_text
executable:     /usr/bin/gdb
kernel:         3.6.10-4.fc18.x86_64
remote_result:  NOTFOUND
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 lookup_minimal_symbol_text at ../../gdb/minsyms.c:368
 #1 create_longjmp_master_breakpoint at ../../gdb/breakpoint.c:3221
 #2 breakpoint_re_set at ../../gdb/breakpoint.c:14198
 #3 solib_add at ../../gdb/solib.c:948
 #4 post_create_inferior at ../../gdb/infcmd.c:477
 #5 core_open at ../../gdb/corelow.c:478
 #6 execute_command at ../../gdb/top.c:487
 #7 catch_command_errors at ../../gdb/exceptions.c:573
 #8 captured_main at ../../gdb/main.c:1056
 #9 catch_errors at ../../gdb/exceptions.c:546

Comment 1 Jan Teichmann 2012-12-30 22:46:09 UTC
Created attachment 670560 [details]
File: backtrace

Comment 2 Jan Teichmann 2012-12-30 22:46:11 UTC
Created attachment 670561 [details]
File: cgroup

Comment 3 Jan Teichmann 2012-12-30 22:46:20 UTC
Created attachment 670562 [details]
File: core_backtrace

Comment 4 Jan Teichmann 2012-12-30 22:46:22 UTC
Created attachment 670563 [details]
File: dso_list

Comment 5 Jan Teichmann 2012-12-30 22:46:23 UTC
Created attachment 670564 [details]
File: environ

Comment 6 Jan Teichmann 2012-12-30 22:46:25 UTC
Created attachment 670565 [details]
File: limits

Comment 7 Jan Teichmann 2012-12-30 22:46:28 UTC
Created attachment 670566 [details]
File: maps

Comment 8 Jan Teichmann 2012-12-30 22:46:30 UTC
Created attachment 670567 [details]
File: open_fds

Comment 9 Jan Teichmann 2012-12-30 22:46:32 UTC
Created attachment 670568 [details]
File: proc_pid_status

Comment 10 Jan Teichmann 2012-12-30 22:46:33 UTC
Created attachment 670569 [details]
File: var_log_messages

Comment 11 Jan Teichmann 2013-01-10 08:54:50 UTC
I noticed more strange memory corruption in other programs recently and as it turned out I had a defective RAM module. Effects were very random and rare but could be the cause of most memory corruption I lately reported. I assumed it is related to the beta state of F18 so I didnt suspect the RAM at first but MemTest found a small address range with errors.
I am extremely sorry for taking up your time hunting down bugs which are most likely not there. I decided to close my latest bug reports as I can not assure that the memory corruption was actually caused by the program rather than the defect RAM module.


Note You need to log in before you can comment on or make changes to this bug.