Bug 89090 - On Redhat 9 mgetty FAX_NOTIFY_PROGRAM new_fax is not executed
On Redhat 9 mgetty FAX_NOTIFY_PROGRAM new_fax is not executed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 11:09 EDT by Hubert Thumfart
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 14:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hubert Thumfart 2003-04-17 11:09:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
After Upgrade from RH80 to RH90 with the same configuration for mgetty, the FAX_NOTIFY_PROGRAM (new_fax) is not exececuted. The faxfile is stored correctly in fax/spool/incoming. Under RH80 with mgetty-1.1.30-0.8.0 it works ok.

Version-Release number of selected component (if applicable):
mgetty-1.1.30-2

How reproducible:
Always

Steps to Reproduce:
1. RH80 works ok
2. RH90 the /etc/mgetty+sendfax/new_fax is not beeing executed
3. Copying /etc/mgetty+sendfax/* to a machine with RH80 works ok
4. Compiling mgetty from original source-tarball does the same
    

Actual Results:  Works on older versions of redhat linux but not on RH90

Expected Results:  Should work on RH90 too.

Additional info:

Maybe a problem of the newer version of gcc ???
Comment 1 Brian Johnson 2003-05-21 11:07:21 EDT
I downloaded and installed the source rpm and found a doc that suggested running
# strings /sbin/mgetty | grep new_fax
to get expected location of new_fax script

It returned:
/etc/mgetty+sendfax/new_fax

I checked permissions of path to /etc/mgetty+sendfax/new_fax and on my system is
read and exec to all users all the way from /
Comment 2 Brian Johnson 2003-05-23 10:10:01 EDT
I guess I never pointed out that it still isn't working

Receiving faxes would be a useful feature to many people (when working), could
it be setup by default when installing the sendfax rpm?  That way the user would
just have to get the modem configured and maybe uncomment some default inittab
lines to get it to work.

Comment 3 Brian Johnson 2003-05-24 00:38:13 EDT
Any chance for a cron script to run every five minutes to process any NEW faxes
in the incoming fax spool directory with the new_fax script until this gets fixed?

It's not a preferrable solution since the caller_id and time will likely be lost
and multi-page faxes won't be grouped together in email notifications but is
better than nothing

PS I have confirmed that the new_fax script works as a command line script as
per the docs in the new_fax.all directory

Comment 4 Brian Johnson 2003-06-09 15:52:39 EDT
With mgetty -x6 /dev/ttyS4 in /etc/inittab I get
06/09 15:41:57 yS4   notify: '/etc/mgetty+sendfax/new_fax 0 '15195555555' 
1  /var/spool/fax/incoming/ffee4e2c1S4-15192715353.01 >/dev/console 2>&1 
</dev/null'

and the sucker works!  I wonder why it didn't before

Back to testing .. I'll let you know
Comment 5 Jason Vas Dias 2004-08-20 14:52:19 EDT
Just clearing out old bugs here.
This does seem to work OK (mgetty-1.1.31)

Note You need to log in before you can comment on or make changes to this bug.