Bug 890921 - Better to give visual prompts when migration failed due to xbzrle is disabled on dst host
Better to give visual prompts when migration failed due to xbzrle is disabled...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Orit Wasserman
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-31 01:26 EST by Qunfang Zhang
Modified: 2014-03-03 19:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 09:55:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2012-12-31 01:26:27 EST
Description of problem:
Migration a guest with xbzrle=on on source host and xbzrle=off on destination host. Migration will fail to load on dst host. Currently the error prompt is not very clear and it will be fine to improve it.

Version-Release number of selected component (if applicable):
kernel-3.6.0-0.29.el7.x86_64
qemu-kvm-1.2.0-21.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot guest on source host and also on dst host with listening mode.

2. Enable xbzrle on source host
(qemu) migrate_set_capability xbzrle on
(qemu) info migrate_capabilities
capabilities: xbzrle: on 

3. Leave the xbzrle as default disabled on destination host
(qemu) info migrate_capabilities
capabilities: xbzrle: off

4.Migrate guest from source host to destination host.
  
Actual results:
On destination host:
(qemu) qemu: warning: error while loading state section id 2
load of migration failed


Expected results:
Better to have some more prompt to let user know the xbzrle is not enabled.
Like:
Failed to load XBZRLE page, it's not enabled!
load of migration failed


Additional info:
Comment 2 Orit Wasserman 2013-12-18 09:55:08 EST
I'm closing this bug because XBZRLE no longer requires enablement in the destination.

Note You need to log in before you can comment on or make changes to this bug.