This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 89100 - Installer/Disk Druid create wrong partition types on dual-boot system
Installer/Disk Druid create wrong partition types on dual-boot system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 12:59 EDT by Bob Jones
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 15:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Jones 2003-04-17 12:59:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When installing RH9 on a dual-boot machine (PIII 1.2Ghz, 256Mb, 20Gb HD)
previously partitioned thusly:
/dev/hda1   10Gb   /dosc  -  Windows 2000/XP Pro partition (fat32)
/dev/hda2   8.5Gb  /      -  Linux partition (ext3)
/dev/hda3   530Mb  <swap> -  Linux swap partition

having fdisk partition types of:
hda1 - c
hda2 - 83
hda3 - 82

from prior installation of RH7.3 and using BootMagic to control OS boot options.
 When installing RH9, there was no option to run fdisk .. only automatically
partition and use Disk Druid.    I ran Disk Druid as I did not want to lose
information on the fat32 partition since its vital for work and to restore user
accounts in Linux.  After several days of trying to figure out what was wrong
and what was keeping BootMagic from properly booting into Windows (hda1), I
booted into RH9 from boot floppy and ran fdisk.  I noticed at this point that
the partition types had been changed to:

hda1 - 1c (hidden fat32)
hda2 - 93 (Amoeba)
hda3 - 82 (Linux Swap)

Only after changing the partition types for hda1 and hda2 back to original and
installing GRUB into the MBR was I able to restore the dual-boot nature of this
laptop.

I do not think its an outright problem with BootMagic sine bootmagic worked
beautifully with RH7.3.  Instead, I believe that there might have been a
partition information communication problem between BM and RH installer.  Adding
the option to use fdisk to manually partition the drives back into the installer
would be a good idea to this user.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.see description
2.
3.
    

Actual Results:  see description

Expected Results:  see description

Additional info:

see description
Comment 1 Michael Fulbright 2003-04-22 11:55:06 EDT
This is most likely an issue with parted.
Comment 2 Jeremy Katz 2004-06-25 15:05:11 EDT
This doesn't appear to be a problem for me with newer releases.

Note You need to log in before you can comment on or make changes to this bug.