Bug 89102 - wrong LANG-setting in /etc/sysconfig/i18n for german installation
wrong LANG-setting in /etc/sysconfig/i18n for german installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
9
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Eido Inoue
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 13:05 EDT by Niels S. Richthof
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 20:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels S. Richthof 2003-04-17 13:05:17 EDT
Description of problem:
chosen settings in the installation process:
language: german
keyboard: de-latin1-nodeadkeys

at first (and following) boot(s), keytable complains:
---[start]---
plus before udiaresis ignored
plus before Udiaresis ignored
plus before odiaresis ignored
plus before Odiaresis ignored
plus before adiaresis ignored
plus before Adiaresis ignored
---[end]---

I found in /etc/sysconfig/i18n:
---[start]---
LANG="de_DE.UTF8"
SYSFONT="latarcyrheb-sun16"
---[end]---


After changing these values to:
---[start]---
LANG="de_DE@euro"
SYSFONT="lat9-16"
---[end]---

it works correctly

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. boot the computer
    
Actual results:
a) excert from /var/log/messages:

Apr 15 14:38:54 poolserver kernel: isapnp: Scanning for PnP cards...
Apr 15 14:38:54 poolserver keytable: 
Apr 15 14:38:54 poolserver kernel: isapnp: CMI8330 quirk - fixing interrupts 
and dma
Apr 15 14:38:54 poolserver keytable: plus before udiaeresis ignored
Apr 15 14:38:54 poolserver kernel: isapnp: Card 'CMI8330. Audio Adapter'
Apr 15 14:38:54 poolserver keytable: plus before Udiaeresis ignored
Apr 15 14:38:54 poolserver kernel: isapnp: 1 Plug & Play card detected total
Apr 15 14:38:54 poolserver keytable: plus before odiaeresis ignored
Apr 15 14:38:54 poolserver kernel: Linux NET4.0 for Linux 2.4
Apr 15 14:38:54 poolserver keytable: plus before Odiaeresis ignored
Apr 15 14:38:54 poolserver kernel: Based upon Swansea University Computer 
Society NET3.039
Apr 15 14:38:54 poolserver keytable: plus before adiaeresis ignored
Apr 15 14:38:54 poolserver kernel: Initializing RT netlink socket
Apr 15 14:38:54 poolserver keytable: plus before Adiaeresis ignored
Apr 15 14:38:54 poolserver kernel: apm: BIOS version 1.2 Flags 0x0b (Driver 
version 1.16)
Apr 15 14:38:54 poolserver rc: Starting keytable:  succeeded
Apr 15 14:38:54 poolserver kernel: Starting kswapd


b) showconsolefont shows kyrillic output


Expected results:
no error messages, correct western font

Additional info:
none
Comment 1 Jeremy Katz 2003-04-22 12:14:11 EDT
anaconda is setting the right thing, but the keyboard description in kbd has
problems
Comment 2 Sven Hummel 2003-04-30 11:30:13 EDT
I have got the same problem and solved it with lat9w-16 for the moment. 
 
But the problem is not solved yet full as the UTF-8 is missing ! 
Also expect problems with UTF-8 in mixed networks. 
Try ssh from a RH9-server with UTF-8 version activated to 
a RH7.3-server running without UTF-8. 
 
How this can be handeled ? 
 
Comment 3 Eido Inoue 2004-02-26 20:57:10 EST
no warnings with fc2-test1 and kbd-1.12-1

Note You need to log in before you can comment on or make changes to this bug.