Bug 891080 - RHEVM-CLI: Wrong error when passing empty kwargs to CLI
RHEVM-CLI: Wrong error when passing empty kwargs to CLI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2013-01-01 10:51 EST by Oded Ramraz
Modified: 2016-02-10 14:32 EST (History)
10 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
When a command containing an empty keyword argument (kwarg) was used in the CLI, an incorrect error message was displayed -'unknown error: need more than 1 value to unpack'. The message did not clearly show what the problem was. The error message now correctly identifies the problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:30:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10678 None None None Never

  None (edit)
Description Oded Ramraz 2013-01-01 10:51:43 EST
Description of problem:

Wrong error when passing empty kwargs ( see additional information )

BTW I'm not sure that kwargs is the best parameter name , since CLI will be used also by non programmers users . 




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[RHEVM shell (connected)]# list quotas --datacenter-identifier 5849b030-626e-47cb-ad90-3ce782d831b3  --kwargs 

unknown error: 'NoneType' object has no attribute 'split'

[RHEVM shell (connected)]# list vms --kwargs 
unknown error: 'NoneType' object has no attribute 'split'
Comment 1 Oded Ramraz 2013-01-01 10:54:04 EST
I would change this error as well: 

[RHEVM shell (connected)]# list vms  --kwargs "ssss"

unknown error: need more than 1 value to unpack
Comment 2 Michael Pasternak 2013-01-03 08:55:41 EST
http://gerrit.ovirt.org/10620
Comment 3 Michael Pasternak 2013-01-06 06:38:16 EST
new patch http://gerrit.ovirt.org/#/c/10678/
Comment 4 Oded Ramraz 2013-02-06 05:01:50 EST
[RHEVM shell (connected)]# list quotas --datacenter-identifier e594779b-92ae-4c07-842c-eca3e427ea59 --kwargs 


error: --kwargs constraint cannot be empty.



Verified sf5
Comment 5 errata-xmlrpc 2013-06-10 16:30:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.