Bug 891143 - man dd has an error regarding kill
man dd has an error regarding kill
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-01 20:33 EST by rmknox
Modified: 2013-01-03 23:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 05:18:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rmknox 2013-01-01 20:33:05 EST
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11
Build Identifier: 

man dd says that to see status of dd when it is running in background, execute this comand: kill -USR1 dd. In fact f17 needs you to use pkill instead of kill

Reproducible: Always

Steps to Reproduce:
1.kill -USR1 dd returns an error
pkill does not
2.
3.
Comment 1 Ondrej Vasik 2013-01-02 01:57:06 EST
Could you please be more specific which error? This may give us better idea what part of OS is faulty here (I don't have F17 on my machine atm. and F17 coreutils dd compiled on RHEL-6 with RHEL-6 kill works just fine, so I'll need to install F17 VM).
Comment 2 Pádraig Brady 2013-01-02 05:18:50 EST
Ever since it was first documented, the pid is used rather than the name:
http://git.sv.gnu.org/gitweb/?p=coreutils.git;a=commitdiff;h=7fd35644
I also confirmed that the latest Fedora 17 source doesn't change this.
Comment 3 rmknox 2013-01-03 23:10:21 EST
I was confused and in error - please forgive the false alarm

Note You need to log in before you can comment on or make changes to this bug.