Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 891148 - backlight brightness adjusting does not work
Summary: backlight brightness adjusting does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-02 01:50 UTC by Ivo Sarak
Modified: 2013-07-05 17:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-05 17:45:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Ivo Sarak 2013-01-02 01:50:50 UTC
Description of problem:
Using function keys, Gnome control nor putting arbitrary values into /sys/class/backlight/acpi_video*/brightness will not change LCD backlight brightness.

Version-Release number of selected component (if applicable):
kernel-3.6.6-3.fc18.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 18 on Lenovo E335
2. Try to adjust LCD brightness
  
Actual results:
No change.

Expected results:
Dimming/intensifying of the LCD backlight brightness.

Additional info:
[ivo@l2ppar ~]$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Device 9808
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:07.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:10.0 USB controller: Advanced Micro Devices [AMD] FCH USB XHCI Controller (rev 03)
00:11.0 SATA controller: Advanced Micro Devices [AMD] FCH SATA Controller [IDE mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices [AMD] FCH USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] FCH USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices [AMD] FCH USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices [AMD] FCH USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] FCH SMBus Controller (rev 14)
00:14.2 Audio device: Advanced Micro Devices [AMD] FCH Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] FCH LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] FCH PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices [AMD] FCH USB OHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 07)
02:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
[ivo@l2ppar ~]$ lsmod
Module                  Size  Used by
fuse                   77993  3 
ebtable_nat            12807  0 
ipt_MASQUERADE         12880  1 
nf_conntrack_netbios_ns    12665  0 
nf_conntrack_broadcast    12527  1 nf_conntrack_netbios_ns
ip6table_mangle        12700  1 
ip6t_REJECT            12939  2 
nf_conntrack_ipv6      14530  23 
nf_defrag_ipv6         18177  1 nf_conntrack_ipv6
iptable_nat            13383  1 
nf_nat                 25414  2 ipt_MASQUERADE,iptable_nat
iptable_mangle         12695  1 
bnep                   19584  2 
bluetooth             317602  7 bnep
nf_conntrack_ipv4      14969  22 nf_nat,iptable_nat
nf_defrag_ipv4         12673  1 nf_conntrack_ipv4
xt_conntrack           12760  42 
nf_conntrack           84045  8 nf_conntrack_netbios_ns,ipt_MASQUERADE,nf_nat,xt_conntrack,nf_conntrack_broadcast,iptable_nat,nf_conntrack_ipv4,nf_conntrack_ipv6
ebtable_filter         12827  0 
ebtables               30757  2 ebtable_nat,ebtable_filter
ip6table_filter        12815  1 
ip6_tables             26942  2 ip6table_filter,ip6table_mangle
be2iscsi               81803  0 
iscsi_boot_sysfs       15641  1 be2iscsi
bnx2i                  54682  0 
cnic                   62653  1 bnx2i
uio                    19044  1 cnic
cxgb4i                 32879  0 
cxgb4                 108492  1 cxgb4i
cxgb3i                 32950  0 
cxgb3                 155601  1 cxgb3i
mdio                   13398  1 cxgb3
libcxgbi               56447  2 cxgb3i,cxgb4i
ib_iser                37812  0 
rdma_cm                42166  1 ib_iser
ib_addr                13745  1 rdma_cm
iw_cm                  18221  1 rdma_cm
ib_cm                  41725  1 rdma_cm
ib_sa                  32955  2 rdma_cm,ib_cm
ib_mad                 46340  2 ib_cm,ib_sa
ib_core                73894  6 rdma_cm,ib_cm,ib_sa,iw_cm,ib_mad,ib_iser
iscsi_tcp              18333  0 
libiscsi_tcp           24128  4 cxgb3i,cxgb4i,iscsi_tcp,libcxgbi
libiscsi               50542  8 libiscsi_tcp,bnx2i,cxgb3i,cxgb4i,be2iscsi,iscsi_tcp,ib_iser,libcxgbi
scsi_transport_iscsi    57490  8 bnx2i,be2iscsi,iscsi_tcp,ib_iser,libcxgbi,libiscsi
microcode              23446  0 
snd_hda_codec_realtek    78081  1 
uvcvideo               80922  0 
videobuf2_vmalloc      12967  1 uvcvideo
videobuf2_memops       13354  1 videobuf2_vmalloc
videobuf2_core         34237  1 uvcvideo
videodev              119976  2 uvcvideo,videobuf2_core
i2c_piix4              13914  0 
k10temp                13126  0 
media                  20444  2 uvcvideo,videodev
snd_hda_codec_hdmi     36232  1 
snd_hda_intel          37618  5 
snd_seq                64844  0 
snd_hda_codec         126889  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_seq_device         14136  1 snd_seq
snd_hwdep              17650  1 snd_hda_codec
snd_pcm                97459  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
lib80211_crypt_tkip    17662  0 
wl                   2600657  0 
cfg80211              196846  1 wl
snd_page_alloc         18101  2 snd_pcm,snd_hda_intel
r8169                  67600  0 
lib80211               13968  2 wl,lib80211_crypt_tkip
mii                    13527  1 r8169
snd_timer              28690  2 snd_pcm,snd_seq
thinkpad_acpi          79408  0 
snd                    79242  20 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_hda_codec,snd_hda_intel,thinkpad_acpi,snd_seq_device
soundcore              14491  1 snd
rfkill                 21384  6 cfg80211,thinkpad_acpi,bluetooth
vhost_net              33859  0 
tun                    22938  1 vhost_net
macvtap                18240  1 vhost_net
macvlan                18731  1 macvtap
kvm_amd                55563  0 
binfmt_misc            17463  1 
kvm                   419458  1 kvm_amd
uinput                 17673  0 
radeon                895780  3 
i2c_algo_bit           13257  1 radeon
drm_kms_helper         44701  1 radeon
ttm                    79760  1 radeon
drm                   255010  5 ttm,drm_kms_helper,radeon
i2c_core               38314  6 drm,i2c_piix4,drm_kms_helper,i2c_algo_bit,radeon,videodev
wmi                    18697  0 
video                  18936  0 
[ivo@l2ppar ~]$

Comment 1 Ivo Sarak 2013-02-17 22:04:01 UTC
The kernel-3.7.7-201.fc18.x86_64 seems to have support for that functionality.

Comment 2 Josh Boyer 2013-02-18 15:12:36 UTC
(In reply to comment #1)
> The kernel-3.7.7-201.fc18.x86_64 seems to have support for that
> functionality.

Does that mean your issue is fixed with 3.7.7?

Comment 3 Ivo Sarak 2013-02-21 18:41:25 UTC
Yes.

Comment 4 Freddy Willemsen 2013-03-13 07:59:24 UTC
Issue persists in kernel 3.8.2-206.fc18.x86_64. I have a Dell Latitude E6530 and have the exact same issue. Tried xbacklight, nvidia blob (with EnableBrightnessControl, this used to work in Fedora 17), nouveau drivers up to latest updates-testing (1.0.6-4.fc18), acpi_backlight=vendor.
'xev' does not even register the XF86MonBrightnessUp and XF86MonBrightnessDown keystrokes. Other Fn keys (like PrintScreen) are working just fine.

I am using the LXDE spin.

As said, Fedora 17 (used up to kernel 3.6, don't know about 3.7) worked without issue.

Comment 5 Sentiono Leowinata 2013-03-13 09:21:22 UTC
Issue persists Linux sentiono 3.8.2-206.fc18.x86_64 #1 SMP Fri Mar 8 15:03:34 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

And it has been problems since F18 released.

It seems that F18 has more problems than F17.
If not due to decision by RedHat to change the upgrade system from F18 onward, I would have stick with F17.

I am using Acer Travelmate 8481TG, NVidia GT520M and Intel.

Comment 6 Sentiono Leowinata 2013-03-19 03:00:27 UTC
Issue persists on Linux sentiono 3.8.3-201.fc18.x86_64 #1 SMP Thu Mar 14 21:28:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Brightness Function keys still not working.

Comment 7 Juan Dayer 2013-04-07 02:52:19 UTC
Hi. The problem about function keys also persists with 3.8.5-201.fc18.x86_64 #1 SMP Thu Mar 28 21:01:19 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Comment 8 Josh Boyer 2013-07-05 17:45:45 UTC
For those of you that don't have identical hardware to the original reporter and are still seeing this issue on 3.9.y kernels, please open a new bug with the relevant details.


Note You need to log in before you can comment on or make changes to this bug.