This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 89115 - agetty crashes on serial consoles
agetty crashes on serial consoles
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 15:28 EDT by Need Real Name
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 15:25:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-17 15:28:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I recently did a fresh install of RH 9 on a server that had previously been 
running RH 7.3.  This machine redirects to a serial console on ttyS0 from grub 
onward.

RH9 kindly put an entry in my inittab to give me a console on the serial 
console.  While it does print the login banner correctly, whenever agetty gets 
its first byte of input from the serial port, it dies.

An strace looks like:

read(0, "", 1)                          = 0
--- SIGHUP (Hangup) @ 0 (0) ---

gdb backtrace is:

#0  0xffffe002 in ?? ()
#1  0x08049224 in alarm ()
#2  0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6

Not very useful, I know.

The serial console worked fine under 7.3, where I was using agetty as well.


Version-Release number of selected component (if applicable):
util-linux- 2.11y

How reproducible:
Always

Steps to Reproduce:
1.Install RH9.0 via serial console
2.Try to login via serial console
3.agetty dies and eventually loops
    

Additional info:
Comment 1 Elliot Lee 2003-05-16 16:12:06 EDT
Will mgetty work?
Comment 2 Need Real Name 2003-05-16 16:27:40 EDT
mgetty works fine.
Comment 3 Elliot Lee 2004-07-28 17:07:00 EDT
Apologies for taking so long to wrap this bug up. I'll remove agetty
from the dist and suggest mgetty as the replacement.
Comment 4 Elliot Lee 2004-08-31 18:23:16 EDT
Well, removing agetty is a pain, so it's back in for now - sorry about
the direction change. I haven't seen other recent reports of problems
like this one, and agetty is in fairly wide use, so I guess the first
priority is finding a portable way to reproduce the problem.
Ideas/comments?
Comment 5 Elliot Lee 2004-12-02 15:25:57 EST
I have a bunch of systems with agetty working. They're all newer than
RHL 9.

Note You need to log in before you can comment on or make changes to this bug.