Bug 891176 - nodejs-abbrev - Abbreviation calculator for Node.js
nodejs-abbrev - Abbreviation calculator for Node.js
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 891171 891210
  Show dependency treegraph
 
Reported: 2013-01-02 02:59 EST by T.C. Hollingsworth
Modified: 2013-01-13 07:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-13 06:57:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhroncok: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-01-02 02:59:30 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-abbrev.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-abbrev-1.0.3-4.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4830923
FAS username: patches

Calculate the set of unique abbreviations for a given set of strings.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 Michael Scherer 2013-01-06 08:50:58 EST
There is no license at all for this one in the tarball, so could it be updated to a newer snapshot ?

( also, can you clean the spec of obsolete stuff like %clean, etc, etc )
Comment 2 T.C. Hollingsworth 2013-01-10 02:26:10 EST
isaacs recently pushed an update that includes a license file.  This version also fixes issues found in other reviews.

Spec: http://patches.fedorapeople.org/npm/nodejs-abbrev.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-abbrev-1.0.4-1.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4854293
Comment 3 Miro Hrončok 2013-01-10 12:58:59 EST
Description and Summary OK.

MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ rpmlint ../SRPMS/nodejs-abbrev-1.0.4-1.src.rpm ../RPMS/noarch/nodejs-abbrev-1.0.4-1.noarch.rpm
nodejs-abbrev.src: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-abbrev.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-abbrev.noarch: W: only-non-binary-in-usr-lib
2 packages and 0 specfiles checked; 0 errors, 3 warnings.

All false positives.

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. OK
MUST: The package must meet the Packaging Guidelines. OK
MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license.

Checked in LICENSE, MIT. OK

MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc. OK
MUST: The spec file must be written in American English. OK
MUST: The spec file for the package MUST be legible. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL.

$ sha256sum ../SOURCES/abbrev-1.0.4.tgz 
8dc0f480571a4a19e74f1abd4f31f6a70f94953d1ccafa16ed1a544a19a6f3a8  ../SOURCES/abbrev-1.0.4.tgz
$ spectool -g nodejs-abbrev.spec 
Getting http://registry.npmjs.org/abbrev/-/abbrev-1.0.4.tgz to ./abbrev-1.0.4.tgz
$ sha256sum abbrev-1.0.4.tgz 
8dc0f480571a4a19e74f1abd4f31f6a70f94953d1ccafa16ed1a544a19a6f3a8  abbrev-1.0.4.tgz

OK

MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. OK
MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. OK, builds in mock
MUST: Packages must NOT bundle copies of system libraries. OK
MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. OK
MUST: A Fedora package must not list a file more than once in the spec file's %files listings. OK
MUST: Permissions on files must be set properly.

$ rpm -q -lv -p ../RPMS/noarch/nodejs-abbrev-1.0.4-1.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led 10 18:35 /usr/lib/node_modules/abbrev
drwxr-xr-x    2 root    root                        0 led 10 18:35 /usr/lib/node_modules/abbrev/lib
-rw-r--r--    1 root    root                     2769 led  9 01:02 /usr/lib/node_modules/abbrev/lib/abbrev.js
drwxr-xr-x    2 root    root                        0 led 10 18:35 /usr/lib/node_modules/abbrev/node_modules
-rw-r--r--    1 root    root                      390 led  9 01:02 /usr/lib/node_modules/abbrev/package.json
drwxr-xr-x    2 root    root                        0 led 10 18:35 /usr/share/doc/nodejs-abbrev-1.0.4
-rw-r--r--    1 root    root                     1092 kvě 13  2011 /usr/share/doc/nodejs-abbrev-1.0.4/LICENSE
-rw-r--r--    1 root    root                      499 říj  4  2010 /usr/share/doc/nodejs-abbrev-1.0.4/README.md

OK

MUST: Each package must consistently use macros. OK
MUST: The package must contain code, or permissable content. OK
MUST: If a package includes something as %doc, it must not affect the runtime of the application. OK
MUST: Packages must not own files or directories already owned by other packages. OK
MUST: All filenames in rpm packages must be valid UTF-8. OK
SHOULD: The reviewer should test that the package builds in mock. OK
SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. OK

Package APPROVED.
Comment 4 T.C. Hollingsworth 2013-01-10 14:39:48 EST
New Package SCM Request
=======================
Package Name: nodejs-abbrev
Short Description: Abbreviation calculator for Node.js
Owners: patches
Branches: f18 el6
InitialCC:
Comment 5 Gwyn Ciesla 2013-01-10 14:58:29 EST
Git done (by process-git-requests).
Comment 6 T.C. Hollingsworth 2013-01-13 06:57:10 EST
Built for Rawhide
;http://koji.fedoraproject.org/koji/taskinfo?taskID=4864255
Comment 7 Fedora Update System 2013-01-13 07:49:55 EST
nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18

Note You need to log in before you can comment on or make changes to this bug.