Bug 89119 - Update of mysql requires perl-DBD-MySQL
Update of mysql requires perl-DBD-MySQL
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-17 16:17 EDT by Christos Cheretakis
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-22 11:22:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christos Cheretakis 2003-04-17 16:17:15 EDT
Description of problem:
Update of mysql requires perl-DBD-MySQL

Version-Release number of selected component (if applicable):
mysql version 3.23.52.3, installed by upgrade to 8.0, was updated to 3.23.54a-4
from updates.redhat.com

How reproducible:
rpm -Fvh * in i386 directory of an exact mirror of updates.redhat.com. These
packages where installed and updated:
-mysql
-mysql-server
-mysql-devel

perl-DBD-MySQL was not installed in the system

Steps to Reproduce:
As above

RPM complains mysql requires perl-DBD-MySQL
    
Actual results:
Packages weren't updated.

Expected results:
Packages should be updated... I assume perl-DBD-MySQL should require mysql, and
not the other way round.

Additional info:
After installing perl-DBD-MySQL 2.1017-3 from 8.0 CDset, everything worked fine.
Comment 1 Patrick Macdonald 2003-04-22 10:36:51 EDT
Trond changed in 3.23.50-2 to fix bug 66349.  mysqlhotcopy (contained in the
mysql package) requires both of these packages at run-time.  From the
mysql.spec file:

* Mon Jun 10 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.50-2
- Add dependency on perl-DBI and perl-DBD-MySQL (#66349)

However, you mention something interesting.  Version 3.23.52-3, which was the
base RHL 8.0 version, also contains these requirements.  From the mysql.spec 
file of 3.23.52-3:

Requires: perl-DBI, perl-DBD-MySQL

So, this requirement was in RHL 8.0 from the beginning.  Did you upgrade from
RHL 7.x?
Comment 2 Christos Cheretakis 2003-04-22 10:43:41 EDT
Well then, there was something wrong with dependency checking when upgrading...

Yes, I upgraded from 7.3+all-updates-to-date to 8.0, and then applied all
updates for 8.0.
Comment 3 Patrick Macdonald 2003-04-22 10:52:05 EDT
Possibly.  It looks as though the mysql package was not upgraded when moving to
RHL 8.0.  Did you upgrade using the "installation upgrade" option in the RHL 8.0
installer? 
Comment 4 Christos Cheretakis 2003-04-22 10:59:39 EDT
"Installation upgrade" is the option that installs the packages that would
otherwise be updated? I'm not sure about the name. If yes, then I did not use
it. I just did a plain-old-update.

BTW, my installation crashed in the post-upgrade phase, but I have a corrupt
anaconda-core. I don't believe that dependencies would fail in that phase
though. If I have the time to repair the core, maybe I'll file another bug... ;-)
Comment 5 Patrick Macdonald 2003-04-22 11:22:48 EDT
A post-upgrade crash, while being a bummer, would have no bearing in this matter.

All I can tell you is that the perl-DBD-MySQL package is now required by the
mysql package.  I just tried reproducing this using RHL 7.3 and upgrading to 8.0
using the installer and did not receive an error.  

I'm glad to see that you installed the perl-DBD-MySQL package and, hopefully,
now have mysql up and running.  

Note You need to log in before you can comment on or make changes to this bug.