This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 891193 - nodejs-glob - A little globber
nodejs-glob - A little globber
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On: 891194 891195 891205
Blocks: 891171 891175 891226
  Show dependency treegraph
 
Reported: 2013-01-02 03:21 EST by T.C. Hollingsworth
Modified: 2013-01-13 08:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-13 08:10:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mhroncok: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-01-02 03:21:01 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-glob.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-glob-3.1.14-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4830981
FAS username: patches

This is a glob implementation in JavaScript. It uses the minimatch library
to do its matching.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 T.C. Hollingsworth 2013-01-10 02:36:31 EST
Updated with empty %build sections and other issues found in various reviews.

Spec: http://patches.fedorapeople.org/npm/nodejs-glob.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-glob-3.1.14-2.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4854324
Comment 2 Miro Hrončok 2013-01-10 13:36:44 EST
Description and Summary OK.

MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

$ rpmlint ../SRPMS/nodejs-glob-3.1.14-2.fc18.src.rpm ../RPMS/noarch/nodejs-glob-3.1.14-2.fc18.noarch.rpm
nodejs-glob.src: W: spelling-error Summary(en_US) globber -> glibber, lobber, gobbler
nodejs-glob.src: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-glob.src: W: spelling-error %description -l en_US minimatch -> mini match, mini-match, mismatch
nodejs-glob.noarch: W: spelling-error Summary(en_US) globber -> glibber, lobber, gobbler
nodejs-glob.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-glob.noarch: W: only-non-binary-in-usr-lib
nodejs-glob.noarch: W: dangling-symlink /usr/lib/node_modules/glob/node_modules/minimatch /usr/lib/node_modules/minimatch
nodejs-glob.noarch: W: dangling-symlink /usr/lib/node_modules/glob/node_modules/inherits /usr/lib/node_modules/inherits
nodejs-glob.noarch: W: dangling-symlink /usr/lib/node_modules/glob/node_modules/graceful-fs /usr/lib/node_modules/graceful-fs
2 packages and 0 specfiles checked; 0 errors, 9 warnings.

All are false positive. Symlinks OK, package requires (among others) npm(graceful-fs), npm(inherits), npm(minimatch). OK

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. OK
MUST: The package must meet the Packaging Guidelines. OK
MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license.

Checked in LICENSE, BSD. OK

MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc. OK
MUST: The spec file must be written in American English. OK
MUST: The spec file for the package MUST be legible. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL.

$ sha256sum ../SOURCES/glob-3.1.14.tgz 
957a06bbea0ff6ea03527ac7b59a3f9b9856874716600a69a05965f7e18f501a  ../SOURCES/glob-3.1.14.tgz
$ spectool -g nodejs-glob.spec 
Getting http://registry.npmjs.org/glob/-/glob-3.1.14.tgz to ./glob-3.1.14.tgz
$ sha256sum glob-3.1.14.tgz 
957a06bbea0ff6ea03527ac7b59a3f9b9856874716600a69a05965f7e18f501a  glob-3.1.14.tgz

OK

MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. OK
MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. OK, builds in mock
MUST: Packages must NOT bundle copies of system libraries. OK
MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. OK
MUST: A Fedora package must not list a file more than once in the spec file's %files listings. OK
MUST: Permissions on files must be set properly.

$ rpm -q -lv -p ../RPMS/noarch/nodejs-glob-3.1.14-2.fc18.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led 10 19:14 /usr/lib/node_modules/glob
-rw-r--r--    1 root    root                    16753 říj 15 17:33 /usr/lib/node_modules/glob/glob.js
drwxr-xr-x    2 root    root                        0 led 10 19:14 /usr/lib/node_modules/glob/node_modules
lrwxrwxrwx    1 root    root                       33 led 10 19:14 /usr/lib/node_modules/glob/node_modules/graceful-fs -> /usr/lib/node_modules/graceful-fs
lrwxrwxrwx    1 root    root                       30 led 10 19:14 /usr/lib/node_modules/glob/node_modules/inherits -> /usr/lib/node_modules/inherits
lrwxrwxrwx    1 root    root                       31 led 10 19:14 /usr/lib/node_modules/glob/node_modules/minimatch -> /usr/lib/node_modules/minimatch
-rw-r--r--    1 root    root                      548 říj 15 17:34 /usr/lib/node_modules/glob/package.json
drwxr-xr-x    2 root    root                        0 led 10 19:14 /usr/share/doc/nodejs-glob-3.1.14
-rw-r--r--    1 root    root                     1310 čec 24 03:27 /usr/share/doc/nodejs-glob-3.1.14/LICENSE
-rw-r--r--    1 root    root                     9042 srp  6 23:05 /usr/share/doc/nodejs-glob-3.1.14/README.md
drwxr-xr-x    2 root    root                        0 led 10 19:14 /usr/share/doc/nodejs-glob-3.1.14/examples
-rw-r--r--    1 root    root                      228 led 19  2012 /usr/share/doc/nodejs-glob-3.1.14/examples/g.js
-rw-r--r--    1 root    root                      218 led 19  2012 /usr/share/doc/nodejs-glob-3.1.14/examples/usr-local.js

OK

MUST: Each package must consistently use macros. OK
MUST: The package must contain code, or permissable content. OK
MUST: If a package includes something as %doc, it must not affect the runtime of the application. OK
MUST: Packages must not own files or directories already owned by other packages. OK
MUST: All filenames in rpm packages must be valid UTF-8. OK
SHOULD: The reviewer should test that the package builds in mock. OK
SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. OK

TODO: There are tests in the package, why not run them in %check section? In case you do this, don't forget to add all required modules (mkdirp, tap) as BRs.

Please, consider solving this TODO.

Package APPROVED.
Comment 3 T.C. Hollingsworth 2013-01-10 14:37:56 EST
New Package SCM Request
=======================
Package Name: nodejs-glob
Short Description: A little globber for Node.js
Owners: patches
Branches: f18 el6
InitialCC:
Comment 4 Jon Ciesla 2013-01-10 14:59:11 EST
Git done (by process-git-requests).
Comment 5 T.C. Hollingsworth 2013-01-13 08:10:51 EST
Built for rawhide.

Note You need to log in before you can comment on or make changes to this bug.