Bug 891207 - nodejs-mute-stream - Basic pass-through stream, but when muted, the bytes are dropped
nodejs-mute-stream - Basic pass-through stream, but when muted, the bytes are...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
: 911078 (view as bug list)
Depends On:
Blocks: 891223 911074
  Show dependency treegraph
 
Reported: 2013-01-02 03:37 EST by T.C. Hollingsworth
Modified: 2013-04-05 19:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-13 06:52:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhroncok: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-01-02 03:37:55 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-mute-stream.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-mute-stream-0.0.3-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4831021
FAS username: patches

Bytes go in, but they don't come out (when muted).

This is a basic pass-through stream, but when muted, the bytes are
silently dropped, rather than being passed through.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 Miro Hrončok 2013-01-07 14:00:13 EST
Description verified from README.md
Summary verified from README.md

TODO: Consider using a summary that actually tells the user, what it is, something like:
Basic pass-through stream, but when muted, the bytes are dropped


MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.

nodejs-mute-stream.src: W: invalid-url URL: https://github.com/isaacs/mute-st HTTP Error 404: Not Found
nodejs-mute-stream.src: W: no-%build-section
nodejs-mute-stream.noarch: W: invalid-url URL: https://github.com/isaacs/mute-st HTTP Error 404: Not Found
nodejs-mute-stream.noarch: W: only-non-binary-in-usr-lib
2 packages and 0 specfiles checked; 0 errors, 4 warnings.

FIX: Correct the URL in the spec (the ned is missing)
FIX: Add %build section (even if empty), it is needed (some tools might want to add something at the beginning or at the end of it)

MUST: The package must be named according to the Package Naming Guidelines. OK
MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. OK
MUST: The package must meet the Packaging Guidelines. OK
MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines. OK
MUST: The License field in the package spec file must match the actual license.

License chcecked in LICENSE file: BSD. OK

MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc. OK
MUST: The spec file must be written in American English. OK
MUST: The spec file for the package MUST be legible. OK
MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use sha256sum for this task as it is used by the sources file once imported into git.

$ sha256sum ../SOURCES/mute-stream-0.0.3.tgz 
7bb2401ad9afaa6f04bc1d2d9411a6e41d7a6198de929d4522e95eeae78b1082  ../SOURCES/mute-stream-0.0.3.tgz
$ wget http://registry.npmjs.org/mute-stream/-/mute-stream-0.0.3.tgz
$ sha256sum mute-stream-0.0.3.tgz 
7bb2401ad9afaa6f04bc1d2d9411a6e41d7a6198de929d4522e95eeae78b1082  mute-stream-0.0.3.tgz

OK

MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. OK
MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense. OK, builds in mock
MUST: Packages must NOT bundle copies of system libraries. OK
MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. OK
MUST: A Fedora package must not list a file more than once in the spec file's %files listings. OK
MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.

$ rpm -q -lv -p ../RPMS/noarch/nodejs-mute-stream-0.0.3-1.fc18.noarch.rpm 
drwxr-xr-x    2 root    root                        0 led  7 19:19 /usr/lib/node_modules/mute-stream
-rw-r--r--    1 root    root                     2787 srp 15 07:15 /usr/lib/node_modules/mute-stream/mute.js
-rw-r--r--    1 root    root                      517 srp 15 07:16 /usr/lib/node_modules/mute-stream/package.json
drwxr-xr-x    2 root    root                        0 led  7 19:19 /usr/share/doc/nodejs-mute-stream-0.0.3
-rw-r--r--    1 root    root                     1310 čec 24 03:16 /usr/share/doc/nodejs-mute-stream-0.0.3/LICENSE
-rw-r--r--    1 root    root                     1338 čec 25 00:19 /usr/share/doc/nodejs-mute-stream-0.0.3/README.md

OK

MUST: Each package must consistently use macros. OK
MUST: The package must contain code, or permissable content. OK
MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present. OK
MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. OK
MUST: All filenames in rpm packages must be valid UTF-8. OK

SHOULD: The reviewer should test that the package builds in mock. OK
SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. OK

Other hints:

TODO: Consider dropping %defattr(-,root,root,-) in %files, it is not needed.
TODO: Remove the BuildRoot variable, it is not needed either.

Please fix the FIX items and consider fixing TODOs.

Resolution: NEEDSWORK.
Comment 2 T.C. Hollingsworth 2013-01-07 20:16:05 EST
Thanks for taking this review!

(In reply to comment #1)
> TODO: Consider using a summary that actually tells the user, what it is,
> something like:
> Basic pass-through stream, but when muted, the bytes are dropped

Fixed.

> MUST: rpmlint must be run on the source rpm and all binary rpms the build
> produces. The output should be posted in the review.
> 
> nodejs-mute-stream.src: W: invalid-url URL:
> https://github.com/isaacs/mute-st HTTP Error 404: Not Found
> nodejs-mute-stream.src: W: no-%build-section
> nodejs-mute-stream.noarch: W: invalid-url URL:
> https://github.com/isaacs/mute-st HTTP Error 404: Not Found

Fixed.

> nodejs-mute-stream.noarch: W: only-non-binary-in-usr-lib

Node modules are installed in /usr/lib consistent with upstream and other interpreted languages in the distribution.

> 2 packages and 0 specfiles checked; 0 errors, 4 warnings.
> 
> FIX: Correct the URL in the spec (the ned is missing)
> FIX: Add %build section (even if empty), it is needed (some tools might want
> to add something at the beginning or at the end of it)

Fixed.
 
> TODO: Consider dropping %defattr(-,root,root,-) in %files, it is not needed.
> TODO: Remove the BuildRoot variable, it is not needed either.

I'd like to retain EL5 constructions for the time being, as discussed in bug 891194.

Spec: http://patches.fedorapeople.org/npm/nodejs-mute-stream.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-mute-stream-0.0.3-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4847373
Comment 3 T.C. Hollingsworth 2013-01-07 20:17:24 EST
Oops, forgot to bump the release when copy/pasting.  Sorry about that.

Spec: http://patches.fedorapeople.org/npm/nodejs-mute-stream.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-mute-stream-0.0.3-2.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4847373
Comment 4 Miro Hrončok 2013-01-08 06:17:16 EST
Package APPROVED.

I suppose you have no %build section in othe packages too, when bored, consider adding it, so the packages can be approved faster.
Comment 5 T.C. Hollingsworth 2013-01-10 01:57:50 EST
New Package SCM Request
=======================
Package Name: nodejs-mute-stream
Short Description: Basic pass-through stream, but when muted, the bytes are dropped
Owners: patches
Branches: f18 el6
InitialCC:
Comment 6 Gwyn Ciesla 2013-01-10 08:03:21 EST
Git done (by process-git-requests).
Comment 7 T.C. Hollingsworth 2013-01-13 06:52:59 EST
BUilt for Rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4864249
Comment 8 Fedora Update System 2013-01-13 07:50:07 EST
nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18
Comment 9 Fedora Update System 2013-01-17 03:51:21 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-async-0.1.22-3.fc18, nodejs-glob-3.1.14-2.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-graceful-fs-1.1.14-2.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-read-installed-0.0.4-2.fc18, nodejs-read-package-json-0.1.12-2.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-rimraf-2.1.1-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-nopt-2.0.0-3.fc18, nodejs-lru-cache-2.2.1-2.fc18, nodejs-mime-1.2.7-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-fstream-0.1.21-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-npm-registry-client-0.2.11-2.fc18, nodejs-form-data-0.0.6-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-lockfile-0.2.1-2.fc18, nodejs-ini-1.0.5-2.fc18, nodejs-couch-login-0.1.15-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-0775/nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18,nodejs-uid-number-0.0.3-4.fc18,nodejs-sigmund-1.0.0-2.fc18,nodejs-osenv-0.0.3-2.fc18,nodejs-nopt-2.0.0-3.fc18,nodejs-lru-cache-2.2.1-2.fc18,nodejs-mime-1.2.7-2.fc18,nodejs-init-package-json-0.0.7-3.fc18,nodejs-fstream-0.1.21-3.fc18,nodejs-delayed-stream-0.0.5-2.fc18,nodejs-proto-list-1.2.2-2.fc18,nodejs-npm-registry-client-0.2.11-2.fc18,nodejs-form-data-0.0.6-2.fc18,nodejs-which-1.0.5-4.fc18,nodejs-chownr-0.0.1-6.fc18,nodejs-opts-1.2.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,nodejs-once-1.1.1-2.fc18,nodejs-lockfile-0.2.1-2.fc18,nodejs-ini-1.0.5-2.fc18,nodejs-couch-login-0.1.15-2.fc18
Comment 10 Jamie Nguyen 2013-02-14 06:17:43 EST
*** Bug 911078 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2013-04-05 19:12:36 EDT
node-gyp-0.9.1-2.fc18, nodejs-async-0.2.6-1.fc18, nodejs-chmodr-0.1.0-2.fc18, nodejs-fstream-npm-0.1.4-1.fc18, nodejs-glob-3.1.21-1.fc18, nodejs-minimatch-0.2.11-1.fc18, nodejs-mkdirp-0.3.5-1.fc18, nodejs-npm-registry-client-0.2.18-2.fc18, nodejs-read-package-json-0.2.2-1.fc18, nodejs-request-2.14.0-1.fc18, nodejs-semver-1.1.4-1.fc18, npm-1.2.14-2.fc18, nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-tar-0.1.16-1.fc18, nodejs-form-data-0.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.