Bug 891238 - nodejs-tar - tar for node
nodejs-tar - tar for node
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Scherer
Fedora Extras Quality Assurance
:
Depends On: 891181 891190 891195 891231
Blocks: 891171 891175
  Show dependency treegraph
 
Reported: 2013-01-02 04:23 EST by T.C. Hollingsworth
Modified: 2013-04-05 19:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 04:21:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
misc: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-01-02 04:23:49 EST
Spec: http://patches.fedorapeople.org/npm/nodejs-tar.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-tar-0.1.14-1.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4831120
FAS username: patches

tar for node.

This package is part of the npm stack and a future F19 Feature for Node.js.

This package may depend on other packages in the npm stack that aren't explicitly
listed as dependencies of this bug.  For more information, see bug 891171.

Please use nodejs-0.6.5-3 or later when building or using this package.
Comment 1 Michael Scherer 2013-01-06 08:19:29 EST
Hi,

so first, nice to have npm deps being in place in rpm, much easier :)

A few notes :

1) %defattr(-,root,root,-)
BuildRoot, 
and cleaning of root before %install
and %clean 

are not needed, can you remove them ?

2) %check is not used ( this would need a few package, tap and rimram, both added as deps on this bugs )

3) could the summary be improved a little :)
Comment 2 T.C. Hollingsworth 2013-01-06 18:08:13 EST
(In reply to comment #1)
> Hi,
> 
> so first, nice to have npm deps being in place in rpm, much easier :)

Absolutely!  Maintaining the deps manually back in the day was a nightmare.

> A few notes :
> 
> 1) %defattr(-,root,root,-)
> BuildRoot, 
> and cleaning of root before %install
> and %clean 
> 
> are not needed, can you remove them ?

As discussed in bug 891194 I'd like to keep these for now if that's okay.

> 2) %check is not used ( this would need a few package, tap and rimram, both
> added as deps on this bugs )

Okay, I'll package the TAP stack soon then.

> 3) could the summary be improved a little :)

Sure, I got kinda lazy with some of them and just left the npm registry summary/description. ;-)
Comment 3 T.C. Hollingsworth 2013-01-07 01:24:42 EST
I've written a better description and summary now.

Spec: http://patches.fedorapeople.org/npm/nodejs-tar.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-tar-0.1.14-2.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4844386
Comment 4 Michael Scherer 2013-01-07 06:53:22 EST
Package is ok, but will be approved once the deps to install it are in, and once url is fixed.

Package Review
==============

Key:
[x] = Pass
[!] = Fail
[-] = Not applicable
[?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package doesn't install properly.
  Note: Installation errors (see attachment)
- Old EL5ims, but packager want to have it in EPEL5
- Url for upstream is https://github.com/isaacs/node-tar 

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[x]: Sources contain only permissible code or content.
[!]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package requires other packages for directories it uses.
[x]: Package uses nothing in %doc for runtime.
[x]: Package is not known to require ExcludeArch.
[x]: Package complies to the Packaging Guidelines
[x]: Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Large documentation must go in a -doc subpackage.
     Note: Documentation size is 10240 bytes in 4 files.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Fully versioned dependency in subpackages, if present.
[x]: Spec file lacks Packager, Vendor, PreReq tags.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).

===== SHOULD items =====

Generic:
[!]: Buildroot is not present
     Note: Buildroot: present but not needed
[!]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[!]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Reviewer should test that the package builds in mock.
[x]: Dist tag is present.
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX tarball generation or download is documented.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define.

===== EXTRA items =====

Generic:
[!]: Rpmlint is run on all installed packages.
     Note: Mock build failed
[x]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Spec file according to URL is the same as in SRPM.


Installation errors
-------------------
INFO: mock.py version 1.1.28 starting...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
Mock Version: 1.1.28
INFO: Mock Version: 1.1.28
Start: lock buildroot
INFO: installing package(s): /home/misc/checkout/git/FedoraReview/891238-nodejs-tar/results/nodejs-tar-0.1.14-2.fc19.noarch.rpm
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/fedora-rawhide-x86_64/root/', 'install', '/home/misc/checkout/git/FedoraReview/891238-nodejs-tar/results/nodejs-tar-0.1.14-2.fc19.noarch.rpm', '--setopt=tsflags=nocontexts']
Erreur : Paquet : nodejs-tar-0.1.14-2.fc19.noarch (/nodejs-tar-0.1.14-2.fc19.noarch)
             Requiert : npm(fstream) < 0.2
Erreur : Paquet : nodejs-tar-0.1.14-2.fc19.noarch (/nodejs-tar-0.1.14-2.fc19.noarch)
             Requiert : npm(fstream) >= 0.1.8
Erreur : Paquet : nodejs-tar-0.1.14-2.fc19.noarch (/nodejs-tar-0.1.14-2.fc19.noarch)
             Requiert : npm(inherits) >= 1
Erreur : Paquet : nodejs-tar-0.1.14-2.fc19.noarch (/nodejs-tar-0.1.14-2.fc19.noarch)
             Requiert : npm(block-stream)
Erreur : Paquet : nodejs-tar-0.1.14-2.fc19.noarch (/nodejs-tar-0.1.14-2.fc19.noarch)
             Requiert : npm(inherits) < 2
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest



Rpmlint
-------
Checking: nodejs-tar-0.1.14-2.fc19.noarch.rpm
nodejs-tar.noarch: W: spelling-error Summary(en_US) js -> dis, ks, j
nodejs-tar.noarch: W: spelling-error %description -l en_US js -> dis, ks, j
nodejs-tar.noarch: W: invalid-url URL: https://github.com/isaacs/tar HTTP Error 404: Not Found
nodejs-tar.noarch: W: only-non-binary-in-usr-lib
nodejs-tar.noarch: W: dangling-symlink /usr/lib/node_modules/tar/node_modules/fstream /usr/lib/node_modules/fstream
nodejs-tar.noarch: W: dangling-symlink /usr/lib/node_modules/tar/node_modules/block-stream /usr/lib/node_modules/block-stream
nodejs-tar.noarch: W: dangling-symlink /usr/lib/node_modules/tar/node_modules/inherits /usr/lib/node_modules/inherits
1 packages and 0 specfiles checked; 0 errors, 7 warnings.




Requires
--------
nodejs-tar (rpmlib, GLIBC filtered):
    nodejs(engine)
    npm(block-stream)
    npm(fstream)
    npm(inherits)



Provides
--------
nodejs-tar:
    nodejs-tar
    npm(tar)



MD5-sum check
-------------
http://registry.npmjs.org/tar/-/tar-0.1.14.tgz :
  CHECKSUM(SHA256) this package     : 8a11b7412e0ab863a96569160d0ad6290fba7531dcc0c10eefab66580cc20126
  CHECKSUM(SHA256) upstream package : 8a11b7412e0ab863a96569160d0ad6290fba7531dcc0c10eefab66580cc20126


Generated by fedora-review 0.2.0 (Unknown) last change: Unknown
Buildroot used: fedora-rawhide-x86_64
Command line :./try-fedora-review -m fedora-rawhide-x86_64 -b 891238
Comment 5 T.C. Hollingsworth 2013-01-10 03:12:15 EST
(In reply to comment #4)
> Issues:
> =======
> - Package doesn't install properly.
>   Note: Installation errors (see attachment)

I assume this is because of the missing deps?  The deps appear correct and matched by packages under review.

> - Old EL5ims, but packager want to have it in EPEL5
> - Url for upstream is https://github.com/isaacs/node-tar 

Fixed.

This version also includes fixes for issues identified in other reviews.

Spec: http://patches.fedorapeople.org/npm/nodejs-tar.spec
SRPM: http://patches.fedorapeople.org/npm/nodejs-tar-0.1.14-3.fc17.src.rpm
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4854430
Comment 6 Michael Scherer 2013-01-10 03:35:01 EST
Yep, that's the missing deps. But as I started on the review, I prefered to paste it as ASAP rather than waiting and forgetting.
Comment 7 Michael Scherer 2013-01-18 06:03:02 EST
So now the deps are in , packag eis approved
Comment 8 T.C. Hollingsworth 2013-01-18 06:09:48 EST
New Package SCM Request
=======================
Package Name: nodejs-tar
Short Description: Tar for Node.js
Owners: patches
Branches: f18 el6
InitialCC:
Comment 9 Jon Ciesla 2013-01-18 06:57:03 EST
Git done (by process-git-requests).
Comment 10 T.C. Hollingsworth 2013-01-19 04:21:40 EST
built for rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4883771
Comment 11 Fedora Update System 2013-01-19 04:55:43 EST
nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-async-0.1.22-3.fc18, nodejs-glob-3.1.14-2.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-graceful-fs-1.1.14-2.fc18, nodejs-minimatch-0.2.9-2.fc18, nodejs-mkdirp-0.3.4-2.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-read-installed-0.0.4-2.fc18, nodejs-read-package-json-0.1.12-2.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-rimraf-2.1.1-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-nopt-2.0.0-3.fc18, nodejs-lru-cache-2.2.1-2.fc18, nodejs-mime-1.2.7-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-fstream-0.1.21-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-npm-registry-client-0.2.11-2.fc18, nodejs-form-data-0.0.6-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-yamlish-0.0.5-1.fc18, nodejs-once-1.1.1-2.fc18, nodejs-lockfile-0.2.1-2.fc18, nodejs-ini-1.0.5-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-config-chain-1.1.3-3.fc18, nodejs-fstream-npm-0.1.3-2.fc18, nodejs-npmconf-0.0.16-3.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-charm-0.1.0-1.fc18, node-gyp-0.8.2-3.fc18, nodejs-tar-0.1.14-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-0775/nodejs-abbrev-1.0.4-2.fc18,nodejs-ansi-0.1.2-4.fc18,nodejs-async-0.1.22-3.fc18,nodejs-glob-3.1.14-2.fc18,nodejs-inherits-1.0.0-6.fc18,nodejs-graceful-fs-1.1.14-2.fc18,nodejs-minimatch-0.2.9-2.fc18,nodejs-mkdirp-0.3.4-2.fc18,nodejs-mute-stream-0.0.3-3.fc18,nodejs-read-1.0.4-4.fc18,nodejs-read-installed-0.0.4-2.fc18,nodejs-read-package-json-0.1.12-2.fc18,nodejs-retry-0.6.0-2.fc18,nodejs-rimraf-2.1.1-2.fc18,nodejs-slide-1.1.3-4.fc18,nodejs-uid-number-0.0.3-4.fc18,nodejs-sigmund-1.0.0-2.fc18,nodejs-osenv-0.0.3-2.fc18,nodejs-nopt-2.0.0-3.fc18,nodejs-lru-cache-2.2.1-2.fc18,nodejs-mime-1.2.7-2.fc18,nodejs-init-package-json-0.0.7-3.fc18,nodejs-fstream-0.1.21-3.fc18,nodejs-delayed-stream-0.0.5-2.fc18,nodejs-proto-list-1.2.2-2.fc18,nodejs-npm-registry-client-0.2.11-2.fc18,nodejs-form-data-0.0.6-2.fc18,nodejs-which-1.0.5-4.fc18,nodejs-chownr-0.0.1-6.fc18,nodejs-opts-1.2.2-2.fc18,nodejs-yamlish-0.0.5-1.fc18,nodejs-once-1.1.1-2.fc18,nodejs-lockfile-0.2.1-2.fc18,nodejs-ini-1.0.5-2.fc18,nodejs-couch-login-0.1.15-2.fc18,nodejs-archy-0.0.2-5.fc18,nodejs-block-stream-0.0.6-4.fc18,nodejs-config-chain-1.1.3-3.fc18,nodejs-fstream-npm-0.1.3-2.fc18,nodejs-npmconf-0.0.16-3.fc18,nodejs-npmlog-0.0.2-2.fc18,nodejs-charm-0.1.0-1.fc18,node-gyp-0.8.2-3.fc18,nodejs-tar-0.1.14-3.fc18
Comment 12 Fedora Update System 2013-04-05 19:17:18 EDT
node-gyp-0.9.1-2.fc18, nodejs-async-0.2.6-1.fc18, nodejs-chmodr-0.1.0-2.fc18, nodejs-fstream-npm-0.1.4-1.fc18, nodejs-glob-3.1.21-1.fc18, nodejs-minimatch-0.2.11-1.fc18, nodejs-mkdirp-0.3.5-1.fc18, nodejs-npm-registry-client-0.2.18-2.fc18, nodejs-read-package-json-0.2.2-1.fc18, nodejs-request-2.14.0-1.fc18, nodejs-semver-1.1.4-1.fc18, npm-1.2.14-2.fc18, nodejs-abbrev-1.0.4-2.fc18, nodejs-ansi-0.1.2-4.fc18, nodejs-inherits-1.0.0-6.fc18, nodejs-mute-stream-0.0.3-3.fc18, nodejs-read-1.0.4-4.fc18, nodejs-retry-0.6.0-2.fc18, nodejs-slide-1.1.3-4.fc18, nodejs-uid-number-0.0.3-4.fc18, nodejs-sigmund-1.0.0-2.fc18, nodejs-osenv-0.0.3-2.fc18, nodejs-init-package-json-0.0.7-3.fc18, nodejs-delayed-stream-0.0.5-2.fc18, nodejs-proto-list-1.2.2-2.fc18, nodejs-which-1.0.5-4.fc18, nodejs-chownr-0.0.1-6.fc18, nodejs-opts-1.2.2-2.fc18, nodejs-once-1.1.1-2.fc18, nodejs-couch-login-0.1.15-2.fc18, nodejs-archy-0.0.2-5.fc18, nodejs-block-stream-0.0.6-4.fc18, nodejs-npmlog-0.0.2-2.fc18, nodejs-opener-1.3.0-4.fc18, nodejs-tobi-cookie-0.3.2-2.fc18, nodejs-promzard-0.2.0-3.fc18, nodejs-combined-stream-0.0.4-1.fc18, nodejs-config-chain-1.1.5-1.fc18, nodejs-fstream-0.1.22-1.fc18, nodejs-fstream-ignore-0.0.6-1.fc18, nodejs-graceful-fs-1.2.0-1.fc18, nodejs-ini-1.1.0-1.fc18, nodejs-lockfile-0.3.0-1.fc18, nodejs-lru-cache-2.2.2-1.fc18, nodejs-mime-1.2.9-1.fc18, nodejs-nopt-2.1.1-1.fc18, nodejs-npmconf-0.0.23-1.fc18, nodejs-read-installed-0.1.1-1.fc18, nodejs-rimraf-2.1.4-1.fc18, nodejs-tar-0.1.16-1.fc18, nodejs-form-data-0.0.7-1.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.